poj 2406 Power Strings (KMp)

这篇博客介绍了解决poj 2406问题的思路,通过应用KMP算法来计算字符串的特征向量next。如果字符串长度len能被(len - next[len])整除,那么最大的循环次数n等于len/(len - next[len]),否则n为1。
摘要由CSDN通过智能技术生成
题意: 给一个字符串S长度不超过10^6,求最大的n使得S由n个相同的字符串a连接而成,如:"ababab"则由n=3个"ab"连接而成,"aaaa"由n=4个"a"连接而成,"abcd"则由n=1个"abcd"连接而成。

定理: 假设S的长度为len,则S存在循环子串,当且仅当,len可以被len - next[len]整除,最短循环子串为S[len - next[len]]

例子证明:

设S=q 1 q 2 q 3 q 4 q 5 q 6 q 7 q 8 ,并设next[8] = 6,此时str = S[len - next[len]] = q 1 q 2 ,由字符串特征向量next的定义可知,q 1 q 2 q 3 q 4 q 5 q = q 3 q 4 q 5 q 6 q 7 q 8 ,即有q 1 q 2 =q 3 q 4 ,q 3 q 4 =q 5 q 6 ,q 5 q 6 =q 7 q 8 ,即q 1 q 2 为循环子串,且易知为最短循环子串。由以上过程可知,若len可以被len - next[len]整除,则S存在循环子串,否则不存在。

解法:利用KMP算法,求字符串的特征向量next,若len可以被len - next[len]整除,则最大循环次数n为len/(len - next[len]),否则为1。


Power Strings

Time Limit : 6000/3000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 83   Accepted Submission(s) : 30
Problem Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
 

Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
 

Output
For each s you should print the largest n such that s = a^n for some string a.
 

Sample Input
  
  
abcd aaaa ababab .
 

Sample Output
  
  
1 4 3
 


#include<stdio.h>
#include<string.h>
#define M 1000010
char str[M];
int n,m,len;
int cnt;
int p[M];
void getp()
{
	int i=0,j=-1;
	p[i]=j;
	while(i<len)
	{
		if(j==-1||str[i]==str[j])
		{
			i++;j++;
			p[i]=j;
		}
		else  j=p[j];	
	}
}
int main()
{
	while(scanf("%s",&str)!=EOF)
	{
		if(strcmp(str,".")==0)
		break;
		len=strlen(str);
		getp();
        if(len%(len-p[len])==0)   // len-p[len]为最小循环子串 
		printf("%d\n",len/(len-p[len]));
        else
		printf("1\n");	//不能整除,肯定会有余出来的数,一定不能构成整数倍的相同字符串		
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值