Radar Installation (贪心!)

 Radar Installation

 

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output
Case 1: 2
Case 2: 1

题意:P为岛屿,在x轴上建立覆盖半径为r的雷达站,求至少需要多少个雷达。

思路:(错误思路)刚开始的时候想的是,先找出最左边的小岛然后从此点向右在x轴上找到一点,使以此点为半径的圆恰好包含之前的小岛,然后继续向右找第一个不在圆内的点,重复以上步骤,但是这种想法是错误的,比如下图的情况,这样的思路就不可以了。

正确思路:每个岛屿在x轴上都对应一个区间,这个区间的含义为,从这个区间内的任意一点为圆心,以r为半径,都可以将此岛屿包含进去。将每个岛屿对应的区间都求出以后,再进行贪心即可。区间存在公共部分,说明区间对应的岛屿可以使用同一个雷达覆盖。

AC代码:

#include<iostream>
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
const int maxn=1005;
using namespace std;

struct Node
{
	double l;
	double r;
}a[maxn];
bool cmp(Node a,Node b)
{
	if(a.l==b.l)
		return a.r<b.r;
	return a.l<b.l;
}
int main()
{
	int n,i,leap,cnt,t=0;
	double x,y,r,flag;
	while(scanf("%d %lf",&n,&r)!=EOF)
	{
		if(n==0&&r==0)break;
		t++;leap=0;
		for(i=1;i<=n;++i)
		{
			scanf("%lf %lf",&x,&y);
			if(r<0||y>r)	leap=1;		 
			a[i].l=x-sqrt(r*r-y*y);			//求出每个岛屿对应的区间 
			a[i].r=x+sqrt(r*r-y*y);			 
		}
		if(leap)
		{
			printf("Case %d: -1\n",t);
			continue;
		}
		sort(a+1,a+1+n,cmp);			//下步从左向右开始合并区间 
		flag=a[1].r;					//选取第一个岛屿区间的右坐标 
		cnt=1;
		for(i=2;i<=n;++i)
		{
			if(a[i].r<flag)				 
			{
				flag=a[i].r;		
			}
			else if(a[i].l>flag)
			{
				cnt++;
				flag=a[i].r;
			}
		}
		printf("Case %d: %d\n",t,cnt);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值