Subsequence POJ - 3061 (尺取法(白书p148))

Subsequence

 POJ - 3061 

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

题意:T组案例,输入n,s。n个数,从中选取连续t个数使这个数的和大于等于s,并使t最小,求t。

思路:尺取法,白书p148有详解,我就不做解释了,时间复杂度O(n)。

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<utility>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<stack>
#define maxn 1000010
#define INF 0x3f3f3f3f
#define LL long long
#define ULL unsigned long long
#define E 1e-8
#define mod 1000000007
#define P pair<int,int>
using namespace std;

int n,a[maxn];
long long s,sum;
int slove() //尺取法
{
    int st=0,en = 0,ans = INF;
    sum = 0;
    for(;;){
        while(en<n&&sum<s){
            sum += a[++en];
        }
        if(sum < s) break;  //说明所有和加起来不大于等于s
        sum -= a[++st];
        ans = min(ans,en-st+1);
    }
    if(ans==INF) return 0;
    else return ans;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d %lld",&n,&s);
        for(int i=1;i<=n;++i){
            scanf("%d",&a[i]);
        }
        printf("%d\n",slove());
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值