hdoj 1142 A Walk Through the Forest

A Walk Through the Forest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6907    Accepted Submission(s): 2542


Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.
 

Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.
 

Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
 

Sample Input
  
  
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0
 

Sample Output
  
  
2 4
 记忆化搜索+迪杰斯特拉!
 
   
//题意:从2到1的所有路径中找出最短的路,并且输出最短路径有几条。
//策略:先求出最短路径,然后再找出从2到1的最短路径有几条。最短路径用dijkstra算法来求出,什么是dijkstra算法,简单来说,dijkstra算法就是路径长度递增次序产生最短路径的算法:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define  N 1010
#define  INF 0xffff
int road,dot,result;
int map[N][N],res[N],cost[N]; 
void dij(int v)//求最短路 
{
	int i,j,k;
	int mincost,next=0,vis[N];
	memset(vis,0,sizeof(vis));
	for(i=1;i<=dot;i++)
	cost[i]=map[v][i];
	vis[v]=1;
	for(i=2;i<=dot;i++)
	{
		mincost=INF;
		for(j=1;j<=dot;j++)
		{
			if(!vis[j]&&cost[j]<mincost)
			{
				mincost=cost[j];
				next=j;
			}
		}
		vis[next]=1;
		for(j=1;j<=dot;j++)
		{
			if(!vis[j]&&map[next][j]+cost[next]<cost[j])
			cost[j]=map[next][j]+cost[next];
		}
	}
}
int dfs(int n)深搜:原理:从1点出发,每次一都找比当前cost[v]小的点,找到2就说明有一条最短路径
{
	int i;
	if(res[n]!=-1)
	 return  res[n];
	if(n==2)
	return 1;
	res[n]=0;
	for(i=1;i<=dot;i++)
	{
		if(map[n][i]!=INF&&cost[n]>cost[i])
		res[n]+=dfs(i);
	}
	return res[n];
}
int main()
{
	int i,j,k;
	while(scanf("%d",&dot)!=EOF)
	{
		result=0;
		if(!dot) 
		break;
		scanf("%d",&road);
		for(i=1;i<=dot;i++)
		{
			map[i][i]=0;
			for(j=i+1;j<=dot;j++)
			 	map[j][i]=map[i][j]=INF;
		}
		int a,b,c;
		for(i=0;i<road;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			if(map[a][b]>c)
			map[a][b]=map[b][a]=c;
		}
		dij(2);
		memset(res,-1,sizeof(res));
		printf("%d\n",dfs(1));
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值