Red and Black(广搜,迷宫)

Red and Black

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.  
 


 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile  
'#' - a red tile  
'@' - a man on a black tile(appears exactly once in a data set)  
 


 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).  
 


 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 


 

Sample Output
  
  
45 59 6 13

 

 

解析:记录从一个点能到达其他相同点的个数

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int map[22][22];                  //标记点是否访问过
char a[22][22];
int n,m,fx,fy,kind;
queue<int> q;
void Init()                    //初始化将四周的的点都设为障碍
{
 int i;
  for(i=0;i<=n;i++) {a[i][0]='#';a[i][m+1]='#';}
  for(i=0;i<=m;i++) {a[0][i]='#';a[n+1][i]='#';}
  memset(map,0,sizeof(map));
}
void bfs(int x,int y)
{
   map[x][y]=++kind;
   q.push(x),q.push(y);                    //先将点的x坐标存入到队列中,然后将y坐标存入到队列中
   while(!q.empty())
   {
    x=q.front();q.pop();                 //先取坐标x,然后出队,
    y=q.front();q.pop();
      if(a[x-1][y]=='.'&&!map[x-1][y])            //判断目前点的前面点是否出现过和是否可走
   {
      map[x-1][y]=++kind;
   q.push(x-1),q.push(y);
   }
      if(a[x+1][y]=='.'&&!map[x+1][y])
   {
      map[x+1][y]=++kind;
   q.push(x+1),q.push(y);
   }
   if(a[x][y-1]=='.'&&!map[x][y-1])
   {
      map[x][y-1]=++kind;
   q.push(x),q.push(y-1);
   }
   if(a[x][y+1]=='.'&&!map[x][y+1])
   {
      map[x][y+1]=++kind;
   q.push(x),q.push(y+1);
   }
   }
}
int main()
{
   int i,j;
   while(scanf("%d%d",&m,&n)!=EOF&&(n+m))
   {
    Init();
      for(i=1;i<=n;i++)
   {
    getchar();
    for(j=1;j<=m;j++) 
    {
     scanf("%c",&a[i][j]);
     if(a[i][j]=='@')
     {
        fx=i;fy=j;
     }
    }
   }
   kind=0;
   bfs(fx,fy);
      printf("%d\n",kind);
   }
   return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值