POJ - 3984 迷宫问题

题目
定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
题意:从题目应该能够理解。
思路:利用广搜(BFS),从0,0开始一层层的搜索,直到找到4,4这个点结束。不过此时要记录每个点的编号,方便最后的输出,当然也可以用链表,把子节点的指针指向根节点,最后再输出。
完整代码如下

#include<stdio.h>
#include<string.h>
#define MAX 6
struct coord{
    int x,y;
    int f;//记录该坐标的父亲在队列中的坐标,方便输出 
};
int main(void)
{
    struct coord s[50];//创建队列 
    int i,j,k;
    int map[MAX][MAX] = {0},book[MAX][MAX]= {0};
    int next[4][2] = {{0,1},{1,0},{0,-1},{-1,0}};//按瞬时针,右下左上进行搜索。 
    for(i=0;i<=4;i++)
    {
        for(j=0;j<=4;j++)
            scanf("%d",&map[i][j]);
    }
    int head = 1,tail = 1;//队列初始化 
    s[tail].x = 0;s[tail].y = 0;//把起点坐标0,0放入队列中。 
    s[tail].f = 0;//此坐标为起点,因此他没有父亲,设为0
    tail++;
    int tx,ty;//临时搜索坐标。 
    while(head < tail)
    {
        for(k=0;k<4;k++)//从根节点向四周扩展。 
        {
            tx = s[head].x + next[k][0];
            ty = s[head].y + next[k][1];
            if(tx < 0 || tx > 4 || ty < 0 || ty > 4)//是否越过边界 
                continue;
            if(book[tx][ty] == 0 && map[tx][ty] == 0)   
            {
                book[tx][ty] = 1;//把符合的坐标放入队列中 
                s[tail].x = tx;
                s[tail].y = ty;
                s[tail].f = head;
                tail++; 
            }
            if(tx == 4 && ty == 4)//如果找到该坐标则停止 
                break;
        }
        if(k < 4)//如果找到该坐标,for会break,此时k<4,则此时跳出外循环。 
            break;
        head++;//根节点舍去 
    }
    int t = tail-1;//此时最后一个点的编号 
    int left[30],right[30],top = 0;//由于是逆序的故创建一个堆栈,把左右左边压入堆栈中。 
    while(t != 0)//起始坐标的父亲为0 
    {
        left[top] = s[t].x;
        right[top] = s[t].y;
        t = s[t].f;top++;
    }
    for(i=top-1;i>0;i--)//把堆栈中坐标输出 
        printf("(%d, %d)\n",left[i],right[i]);
    printf("(%d, %d)",left[0],right[0]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,可以得知这是一道关于迷宫问题的题目,需要使用Java语言进行编写。具体来说,这道题目需要实现一个迷宫的搜索算法,找到从起点到终点的最短路径。可以使用广度优先搜索或者深度优先搜索算法来解决这个问题。 下面是一个使用广度优先搜索算法的Java代码示例: ```java import java.util.*; public class Main { static int[][] maze = new int[5][5]; // 迷宫地图 static int[][] dir = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}}; // 方向数组 static boolean[][] vis = new boolean[5][5]; // 标记数组 static int[][] pre = new int[5][5]; // 记录路径 public static void main(String[] args) { Scanner sc = new Scanner(System.in); for (int i = 0; i < 5; i++) { for (int j = 0; j < 5; j++) { maze[i][j] = sc.nextInt(); } } bfs(0, 0); Stack<Integer> stack = new Stack<>(); int x = 4, y = 4; while (x != 0 || y != 0) { stack.push(x * 5 + y); int t = pre[x][y]; x = t / 5; y = t % 5; } stack.push(0); while (!stack.empty()) { System.out.print(stack.pop() + " "); } } static void bfs(int x, int y) { Queue<Integer> qx = new LinkedList<>(); Queue<Integer> qy = new LinkedList<>(); qx.offer(x); qy.offer(y); vis[x][y] = true; while (!qx.isEmpty()) { int tx = qx.poll(); int ty = qy.poll(); if (tx == 4 && ty == 4) { return; } for (int i = 0; i < 4; i++) { int nx = tx + dir[i][0]; int ny = ty + dir[i][1]; if (nx >= 0 && nx < 5 && ny >= 0 && ny < 5 && maze[nx][ny] == 0 && !vis[nx][ny]) { vis[nx][ny] = true; pre[nx][ny] = tx * 5 + ty; qx.offer(nx); qy.offer(ny); } } } } } ``` 该代码使用了广度优先搜索算法,首先读入迷宫地图,然后从起点开始进行搜索,直到找到终点为止。在搜索的过程中,使用标记数组记录已经访问过的位置,使用路径数组记录路径。最后,使用栈来输出路径。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值