POJ-3320 Jessica's Reading Problem(求最小区间,尺取法)

Description

Jessica’s a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica’s text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica’s text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1
Sample Output

2

挑战程序设计例题,求一个最小的区间包括出现的全部知识点。直接利用尺取法,不过先要利用set获得知识点的种类,然后再用map记录知识点的标号和次数,不过应该也能用其他的来实现,利用set类的,用二叉树来存储就行,注意在扫描区间时知识点的消失。

代码如下:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<set>
#include<map>
#include<vector>
using namespace std;
const int MAX = 1e6+10;
int P,l,r,IdeaNum,num;
int a[MAX];
int ans = P;
map<int,int> mp;//first知识点编号,second次数
void solve(){
    l = 1,r = 1,num = 0;//代表该区间知识点的数量
    while(true){
        while(r <= P && num < IdeaNum){
            if(mp[a[r]]++ == 0)//如果是0就表示这是一个新的知识点.
                num++;
            r++;
        }
        printf("%d %d \n",l,r);
        if(num < IdeaNum)   break;//从这个位置无法找到全部知识点故跳出
        ans = min(ans,r-l);
        if(--mp[a[l]] = 0)//代表这个区间有一个知识点没有了,
            num--;
        l++;
    }
}
int main(void)
{
    scanf("%d",&P);
    set<int> st;//统计知识点的种类.
    for(int i=1;i<=P;i++){
        scanf("%d",&a[i]);
        st.insert(a[i]);
    }
    IdeaNum = st.size();
    solve();
    printf("%d\n",ans);
    return 0;
}

何日我能辉煌?

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值