动态规划之 01背包(一维,二维)

例题 HDU 2602 Bone Collector
传送门

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output
14

Author
Teddy

裸的背包问题,就是n个物品,每个都有w[i]的重量,v[i]的价值,W重量的背包可以装的最大价值是多少

最简单的思路肯定是一个递归,一种情况是拿,一种是不拿,看那个的总价值最高,但这时间复杂度是O(2^n)肯定是无法ac,因为有大量的数据被重复计算,如果我们把这些数据提前存储起来,就能把时间复杂度降到O(nw)

代码如下

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<vector>
#include<algorithm>

using namespace std;
const int MAX = 1010;
int w[MAX],v[MAX];
int dp[MAX][MAX];
int t,n,W;
int get(int i,int j){//表示第i个背包,空间剩余为j时的价值
    if(dp[i][j] >= 0){
        return dp[i][j];
    }
    int res;
    if(i == n)  res = 0;//当到达最后一个时,没有背包可以选择了,
    else if(j < w[i]){
        res = get(i+1,j);//不选这个背包
    }
    else res = max(get(i+1,j),get(i+1,j-w[i]) + v[i]);//返回选择或不选择这个背包中的最大的一个价值

    dp[i][j] = res;//存储数据
    return res;
}
int main(void){

    scanf("%d",&t);
    while(t--){
        scanf("%d %d",&n,&W);
        for(int i=0;i<n;i++){
            scanf("%d",&v[i]);
        }
        for(int i=0;i<n;i++){
            scanf("%d",&w[i]);
        }
        memset(dp,-1,sizeof(dp));
        int res = get(0,W);//表示第i个背包,当前剩余重量空间
        printf("%d\n",res);
    }

    return 0;
}

递推公式的如下

#include<cstdio>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;
const int MAX = 1010;
int v[MAX],w[MAX];
int dp[MAX][MAX];
int t,n,W;
int main(void){
    scanf("%d",&t);
    while(t--){
        scanf("%d %d",&n,&W);
        for(int i=0;i<n;i++)
            scanf("%d",&v[i]);
        for(int i=0;i<n;i++)
            scanf("%d",&w[i]);
        //dp[i][j]表示从前i个背包,j为最大重量选取的最大价值
        for(int i=0;i<n;i++){
            for(int j=0;j<=W;j++){
                if(j < w[i])
                    dp[i+1][j] = dp[i][j];
                else
                    dp[i+1][j] = max(dp[i][j],dp[i][j-w[i]] + v[i]);//选或者不选中最大的一个
            }
        }
        printf("%d\n",dp[n][W]);
    }
    return 0;
}

背包压缩为一维数组。
核心代码如下:

void solve(){
    for(int i=1;i<=N;++i){
        for(int j=W;j>=0;--j){
            //如果j从0开始,那么如果在后面使用dp[j-w[i]]时,就不是上一次的,而是本次更新过的。
            dp[j] = max(dp[j],dp[j-w[i]] + v[i]);
        }
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值