poj 1679 The Unique MST (最小生成树是否唯一)

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V’, E’), with the following properties:
1. V’ = V.
2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E’) of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E’.
Input
The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output
For each input, if the MST is unique, print the total cost of it, or otherwise print the string ‘Not Unique!’.
Sample Input
2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2
Sample Output
3
Not Unique!

这个题真的是有点伤啊,没有给m的范围,我直接开到10000就过了,这个题的题意就是让你判断,给出的边,能构成的最下生成树是否唯一,就是只有这一种构图方法,使用其他的都会是最后的花费变大

思路就是先用Kruskra跑一遍,然后得到一个最小的花费dis_min,然后把使用的边全部存到一个数组如basic中,最后再把basic中的边逐个取消,就是不适用这条边,再用kruskra,如果结果等于dis_min,那么结果不止一个,如果没有就在最后输出dis_min,中间我犯了一个傻逼错误,把记录边的输出开成了点的最大范围,结果一直run,真的是,头皮发麻

代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<vector>
#include<algorithm>

using namespace std;
const int MAX_V = 110;
const int MAX_E = 10100;
int t,V,E;
int pre[MAX_V];
struct Edge{
    int x,y,z;
};
struct Edge q[MAX_E];
int Find(int x){
    int r = x;
    while(pre[r] != r)
        r = pre[r];
    int i = x,j;
    while(i != r){
        j = pre[i];
        pre[i] = r;
        i = j;
    }
    return r;
}

bool add(int x,int y){
    int fx = Find(x),fy = Find(y);
    if(fx != fy){
        pre[fx] = fy;
        return true;
    }
    return false;
}

void init(){//并查集的初始化
    for(int i=1;i<=V;i++)
        pre[i] = i;
}

int Kruskal(int s_){//在不使用s_的最小生成树
    int res = 0,Count = 0;;
    for(int i=1;i<=E;i++){
        if(i != s_ && add(q[i].x,q[i].y)){
            res += q[i].z;
            Count++;
        }
        if(Count == V-1)    return res;
    }
    return -1;
}
bool cmp(Edge a,Edge b){
    return a.z < b.z;
}
int basic[MAX_V],top,dis_min;
int main(void){
    scanf("%d",&t);
    while(t--){
        scanf("%d %d",&V,&E);
        for(int i=1;i<=E;i++)
            scanf("%d %d %d",&q[i].x,&q[i].y,&q[i].z);
        init();
        top = 0;dis_min = 0;
        sort(q+1,q+1+E,cmp);
        for(int i=1;i<=E;i++){
            if(add(q[i].x,q[i].y)){
                basic[++top] = i;//记录使用的边
                dis_min += q[i].z;
            }
            if(top == V-1)  break;
        }
        bool isok = true;
        for(int i=1;i<=top;i++){//枚举使用过的边
            init();
            int dis = Kruskal(basic[i]);
            if(dis == -1)   break;//如果无法构成最小生成树,直接跳出
            if(dis == dis_min){
                isok = false;
                break;
            }
        }
        if(isok)    printf("%d\n",dis_min);
        else printf("Not Unique!\n");
    }

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值