POJ 1861 Network(求连接的边) 水题

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs).
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections.
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied.
Input
The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 10 6. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.
Output
Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.
Sample Input
4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1
Sample Output
1
4
1 2
1 3
2 3
3 4

发现这题,出题人简直就是千方百计不让你读懂,其实就是一个最小生成树,使连接的最小生成树中的边的最大的一个权值最小,直接用kruskal算法就行了,把连接的边都记录进去,然后用一个max扫描一下连接边的最大权值

代码如下:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<string>
#include<algorithm>

using namespace std;
const int MAX_V = 1010;
const int MAX_E = 15010;
int V,E;
int pre[MAX_V];
int Find(int x){
    int r = x;
    while(pre[r] != r)
        r = pre[r];
    int i = x,j;
    while(pre[i] != r){
        j = pre[i];
        pre[i] = r;
        i = j;
    }
    return r;
}

bool add(int x,int y){
    int fx = Find(x),fy = Find(y);
    if(fx != fy){
        pre[fx] = fy;
        return true;
    }
    return false;
}
void init(){
    for(int i=1;i<=V;i++)
        pre[i] = i;
}
struct Edge{
    int x,y,z;
}q[MAX_E],res[MAX_V*2];

bool cmp(Edge a,Edge b){
    return a.z < b.z;
}
int main(void){
    scanf("%d %d",&V,&E);
    for(int i=1;i<=E;i++){
        scanf("%d %d %d",&q[i].x,&q[i].y,&q[i].z);
    }
    sort(q+1,q+1+E,cmp);
    int top = 0,Count = 0;
    init();
    int Max = 0;
    for(int i=1;i<=E;i++){
        if(add(q[i].x,q[i].y)){
            Count++;
            Max = max(q[i].z,Max);
            res[++top] = q[i];
        }
        if(Count == V-1)    break;
    }
    printf("%d\n",Max);
    printf("%d\n",top);
    for(int i=1;i<=top;i++){
        printf("%d %d\n",res[i].x,res[i].y);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值