POJ 3660 Floyd求传递闭包

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input
* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output
* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2

题意就是:给出你你x奶牛能战胜y奶牛,问你能确定哪些奶牛的排名

一个传递闭包问题,实际上就是用FLoyd求出任意一个点,能到达那些的以及那些的能到达这个点,如果某一个点,符合能到达他的点的个数加上他能到达点的个数 == n-1(没有他自己),那么他的排名就能确立,不明白可以把样例画出来

代码如下:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<vector>
#include<string>
#include<algorithm>

using namespace std;
const int MAX_V = 110;
bool e[MAX_V][MAX_V];
int N,M;
void floyd(){
    for(int k=1;k<=N;k++){//floyd中k必须要放在最外层
        for(int i=1;i<=N;i++){
            for(int j=1;j<=N;j++){
                if(e[i][k] && e[k][j])
                    e[i][j] = true;
            }
        }
    }
}
int main(void){
    while(scanf("%d %d",&N,&M) != EOF){
        int x,y;
        memset(e,false,sizeof(e));
        for(int i=1;i<=M;i++){
            scanf("%d %d",&x,&y);
                e[x][y] = true;
        }
        floyd();
        int res = 0;
        for(int i=1;i<=N;i++){
            int sum = 0;
            for(int j=1;j<=N;j++){
                if(i == j)  continue;
                if(e[i][j] || e[j][i])
                    sum++;
            }
            if(sum == N-1)  res++;

        }
        printf("%d\n",res);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值