POJ 3187 Backward Digit Sums (全排列+数字金字塔)

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this:

3   1   2   4

  4   3   6

    7   9

     16

Behind FJ’s back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ’s mental arithmetic capabilities.

Write a program to help FJ play the game and keep up with the cows.
Input
Line 1: Two space-separated integers: N and the final sum.
Output
Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.
Sample Input
4 16
Sample Output
3 1 2 4
Hint
Explanation of the sample:

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

给你一个数字金字塔的层数和,塔顶的和,求出对应的底层序列是多少,因为底层序列是可以由1-N构成的而N最大是10,所以可以暴搜出所有的序列,然后再求出最高的塔顶,查看是否相等即可。
对于数字金字塔顶层的和,和底层的关系是C(0,N)+ C(1,N) + .. + C(N,N) 这是个数的关系,乘上对应的数就可以。

代码如下:

#include<iostream>
#include<vector>
#include<string>
#include<algorithm>

using namespace std;
const int MAX = 12;
int N,sum;
int s[MAX];
vector<int> vec;
void init(){
    s[0] = 1;
    for(int i=1;i<=10;++i){
        s[i] = s[i-1]*i;
    }
}
int Get(int i,int C){//求C(i,n)的组合数
    int res = s[C]/s[i]/s[C-i];
    return res;
}
bool OK(){//判断这个序列是否可行
    int res = 0;
    for(int i=0;i<vec.size();++i){
        res += Get(i,N-1)*vec[i];
    }
    if(res == sum){
        return true;
    }
    else{
        return false;
    }
}
void solve(){

    for(int i=1;i<=N;++i){
        vec.push_back(i);
    }
    do{
        if(OK()){
            for(int i=0;i<vec.size();++i){
                cout << vec[i];
                if(i != vec.size() - 1)
                    cout << " ";
            }
            cout << endl;
            return;
        }
    }while(next_permutation(vec.begin(),vec.end()));//求全排列

}
int main(void){
    init();

    cin >> N >> sum;
    solve();

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值