[NOIP2013 普及组] 计数问题
题目描述
试计算在区间 1 1 1 到 n n n 的所有整数中,数字 x x x( 0 ≤ x ≤ 9 0\le x\le9 0≤x≤9)共出现了多少次?例如,在 1 1 1 到 11 11 11 中,即在 1 , 2 , 3 , 4 , 5 , 6 , 7 , 8 , 9 , 10 , 11 1,2,3,4,5,6,7,8,9,10,11 1,2,3,4,5,6,7,8,9,10,11 中,数字 1 1 1 出现了 4 4 4 次。
输入格式
2 2 2 个整数 n , x n,x n,x,之间用一个空格隔开。
输出格式
1 1 1 个整数,表示 x x x 出现的次数。
样例 #1
样例输入 #1
11 1
样例输出 #1
4
提示
对于 100 % 100\% 100% 的数据, 1 ≤ n ≤ 1 0 6 1\le n\le 10^6 1≤n≤106, 0 ≤ x ≤ 9 0\le x \le 9 0≤x≤9。
样例代码
#include<bits/stdc++.h>
using namespace std;
int main(){
// freopen(".in", "w", stdin);
// freopen(".out", "r", stdout);
int n, x, cnt = 0;
cin >> n >> x;
for(int i = 1; i <= n; i++){
int t = i;
while(t != 0){
if(t % 10 == x){
cnt++;
}
t /= 10;
}
}
cout << cnt;
return 0;
}