Prime Time

 

Euler is a well-known matematician, and, among many other things, he discovered that the formula
n^2 + n + 41 produces a prime for 0 ≤ n < 40. For n = 40, the formula produces 1681, which is 41 ∗ 41.
Even though this formula doesn’t always produce a prime, it still produces a lot of primes. It’s known
that for n ≤ 10000000, there are 47,5% of primes produced by the formula!
So, you’ll write a program that will output how many primes does the formula output for a certain
interval.


Input
Each line of input will be given two positive integer a and b such that 0 ≤ a ≤ b ≤ 10000. You must
read until the end of the file.


Output
For each pair a, b read, you must output the percentage of prime numbers produced by the formula in
this interval (a ≤ n ≤ b) rounded to two decimal digits.


Sample Input
0 39
0 40
39 40


Sample Output
100.00
97.56
50.00

题意,根据n*n+n+41,来判断在一个范围内素数站的比例。

想哭都找不到方向敲打大哭,因为一个素数打表,终于懂了一个细节问题,看代码。其中注意一个细节,有一个四舍五入,如果不好写就在答案上直接加1e-8;

#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
int s[10011];
int prime(int l)
{
	int j;
	for(j=2;j<=(int)sqrt(l);j++)
	{
		if(l%j==0)
		return 0;
	}	
	return 1;	
}
void db()
{
	long long l,i,j;s[0]=1;
	for(int i=1;i<10011;i++)
	{
		l=i*i+i+41;
		if(prime(l))
		s[i]=s[i-1]+1;
		else
		s[i]=s[i-1];
	}
}
int main()
{
	int a,b,k;db();//注意要是打表,它的位置不可再while循环内,否则会超时。
	while(scanf("%d%d",&a,&b)!=EOF)
	{
		
		k=s[b]-s[a]+prime(a*a+a+41);
		double h=k*1.0/(b-a+1)*100;
		//h=(int)(h*10000+0.5)/100.0;
		printf("%.2lf\n",h+1e-8);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值