HDU 2266

16 篇文章 0 订阅

How Many Equations Can You Find

Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.
 

Input

Each case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.
 

Output

The output contains one line for each data set : the number of ways you can find to make the equation.
 

Sample Input

    
    
123456789 3 21 1
 

Sample Output

  
  
18 1


题意:给一个数字串,可以在两个数之间添加+,- 求得到n的方法数

直接暴力dfs


#include <stdio.h>
#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
#include <string>
#include <map>
#include <cmath>
#include <queue>
#include <set>

using namespace std;

#define WIN
#ifdef WIN
typedef __int64 LL;
#define iform "%I64d"
#define oform "%I64d\n"
#define oform1 "%I64d"
#else
typedef long long LL;
#define iform "%lld"
#define oform "%lld\n"
#define oform1 "%lld"
#endif

#define S64I(a) scanf(iform, &(a))
#define P64I(a) printf(oform, (a))
#define S64I1(a) scanf(iform1, &(a))
#define P64I1(a) printf(oform1, (a))
#define FOR(i, s, t) for(int (i)=(s); (i)<(t); (i)++)

const int INF = 0x3f3f3f3f;
const double eps = 10e-9;
const double PI = (4.0*atan(1.0));

const int maxn = 20;
int len;
char s[maxn];
LL ans;
LL n;

void dfs(int cur, LL sum) {
    if(cur == len) {
        if(sum == n) ans++;
        return ;
    }
    LL t = 0;
    for(int i=cur; i<len; i++) {
        t = t * 10 + s[i] - '0';
        dfs(i+1, sum + t);
        if(cur > 0) dfs(i+1, sum-t);
    }
}

int main() {
    
    while(scanf("%s", s) != EOF) {
        S64I(n);
        len = strlen(s);
        ans = 0;
        dfs(0, 0);
        P64I(ans);
    }
    
    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值