HDU-2266-How Many Equations Can You Find【交叉DFS】

题目链接:点击打开链接

How Many Equations Can You Find

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 919    Accepted Submission(s): 613


Problem Description
Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.
 

Input
Each case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.
 

Output
The output contains one line for each data set : the number of ways you can find to make the equation.
 

Sample Input
  
  
123456789 3 21 1
 

Sample Output
  
  
18 1

大意:给你一个字符串,你可以在任意字符中间加入 “+” 或 “-”,使得最后的运算结果为 n

思路:从起始位置到最后位置的搜索,加、减交叉搜索,注意第一个字符前不能添减号(实际上是不能添任何符号的,但是添一个加号还是其本身,所以添不添加号无所谓了)

#include<cstdio>
#include<algorithm>
#include<cstring>
#define LL long long
using namespace std;
LL n,ans;
int len;
char str[50];
void dfs(int id,LL sum)
{
	if(id==len) // 这里判 id==len是因为下面 dfs的是 i+1,如果改成 id==n-1,则字符串的最后一位就没计算了 
	{
		if(sum==n)
		{
			ans++;
		}
		return ;
	}
	LL shu=0;
	for(int i=id;i<len;i++)
	{
		shu=shu*10+str[i]-'0';
		dfs(i+1,sum+shu);
		if(id)
			dfs(i+1,sum-shu);
	}
}
int main()
{
	while(~scanf("%s%lld",str,&n))
	{
		len=strlen(str);
		ans=0;
		dfs(0,0);
		printf("%lld\n",ans);
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值