Catalan数的应用与代码实现

ACM中出现的Catalan数与大数结合使用

http://acm.hdu.edu.cn/showproblem.php?pid=1023

Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.
  Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.
  Output
For each test case, you should output how many ways that all the trains can get out of the railway.
  Sample Input
  
  
1 2 3 10
  Sample Output
  
  
1 2 5 16796



http://acm.hdu.edu.cn/showproblem.php?pid=1134

Problem Description
This is a small but ancient game. You are supposed to write down the numbers 1, 2, 3, ... , 2n - 1, 2n consecutively in clockwise order on the ground to form a circle, and then, to draw some straight line segments to connect them into number pairs. Every number must be connected to exactly one another. And, no two segments are allowed to intersect.

It's still a simple game, isn't it? But after you've written down the 2n numbers, can you tell me in how many different ways can you connect the numbers into pairs? Life is harder, right?
  Input
Each line of the input file will be a single positive number n, except the last line, which is a number -1. You may assume that 1 <= n <= 100.
  Output
For each n, print in a single line the number of ways to connect the 2n numbers into pairs.
  Sample Input
  
  
2 3 -1
  Sample Output
  
  
2 5


http://acm.hdu.edu.cn/showproblem.php?pid=1130


Problem Description
A binary search tree is a binary tree with root k such that any node v reachable from its left has label (v) <label (k) and any node w reachable from its right has label (w) > label (k). It is a search structure which can find a node with label x in O(n log n) average time, where n is the size of the tree (number of vertices). 

Given a number n, can you tell how many different binary search trees may be constructed with a set of numbers of size n such that each element of the set will be associated to the label of exactly one node in a binary search tree? 
  Input
The input will contain a number 1 <= i <= 100 per line representing the number of elements of the set.
  Output
You have to print a line in the output for each entry with the answer to the previous question.
  Sample Input
  
  
1 2 3
  Sample Output
  
  
1 2 5



三个题中为同一代码,以下为AC代码:

1134中要加入判断是-1的情况

if(n==-1)
     break;



#include <iostream>
#include <stdio.h>
#include <cmath>
using namespace std;

//h(n)=h(n-1)*(4*n-2)/(n+1);

int a[105][105];    //大数卡特兰数,二维数组,第一维表示有多少位,第二维就是每一位上的数字
int b[105];         //卡特兰数的长度

void catalan()  //求卡特兰数
{
    int i, j, len, carry, temp;
    a[1][0] = b[1] = 1;
    len = 1;
    for(i = 2; i <= 100; i++)
    {
        for(j = 0; j < len; j++)    //乘法
            a[i][j] = a[i-1][j]*(4*(i-1)+2);
        carry = 0;
        for(j = 0; j < len; j++)    //处理相乘结果
        {
            temp = a[i][j] + carry;
            a[i][j] = temp % 10;
            carry = temp / 10;
        }
        while(carry)    //进位处理
        {
            a[i][len++] = carry % 10;
            carry /= 10;
        }
        carry = 0;
        for(j = len-1; j >= 0; j--) //除法
        {
            temp = carry*10 + a[i][j];
            a[i][j] = temp/(i+1);
            carry = temp%(i+1);
        }
        while(!a[i][len-1])     //高位零处理
            len --;
        b[i] = len;
    }
}

int main()
{
    int i, n;
    catalan();
    while(scanf("%d", &n) != EOF)
    {
        for(i = b[n]-1; i>=0; i--)
        {
            printf("%d", a[n][i]);
        }
        printf("\n");
    }

    return 0;
}


Java实现大数据果然简单啊、、

以下为实现100位以的catalan数的代码

import java.math.BigInteger;
import java.util.Scanner;


public class Catalan {

	static final int Max = 101;
	public static void main(String[] args) {
		
		BigInteger catalan[] = new BigInteger[Max];
		catalan[0]=new BigInteger("1");
		calcCatalan(catalan);
		Scanner s = new Scanner(System.in);
		int n = s.nextInt();
		while(n!=-1)
		{
			System.out.println(catalan[n]);
			n = s.nextInt();
		}
	}

	private static void calcCatalan(BigInteger catalan[]) {
		BigInteger four = new BigInteger("4");
		BigInteger two = new BigInteger("2");
		BigInteger one = new BigInteger("1");
		for(int i=1;i<Max;i++)
		{
			//h(n)=h(n-1)*(4*n-2)/(n+1);
			catalan[i]=catalan[i-1].multiply(four.multiply(new BigInteger(i+"")).
					subtract(two)).divide(new BigInteger(i+"").add(one));
		}
	}

}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值