数据结构实验之二叉树七:叶子问题
Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^
题目描述
已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立该二叉树并按从上到下从左到右的顺序输出该二叉树的所有叶子结点。
输入
输入数据有多行,每一行是一个长度小于
50
个字符的字符串。
输出
按从上到下从左到右的顺序输出二叉树的叶子结点。
示例输入
abd,,eg,,,cf,,, xnl,,i,,u,,
示例输出
dfg uli
提示
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
struct Tnode
{
char d;
Tnode *l,*r;
};
char st[60];
int i;
Tnode *CreatTree()
{
Tnode *p;
if(st[i++]==',')
p= NULL;
else
{
p=new Tnode;
p->d=st[i-1];
p->l=CreatTree();
p->r=CreatTree();
}
return p;
}
void level_order(Tnode *p) //层次遍历
{
queue<Tnode *>q;
if(p!=NULL)
q.push(p);
while(!q.empty())
{
p=q.front();
if(!p->l&&!p->r)
cout<<p->d;
q.pop();
if(p->l)
q.push(p->l);
if(p->r)
q.push(p->r);
}
}
int main()
{
while(cin>>st)
{
i=0;
Tnode *Tree=CreatTree();
level_order(Tree);
cout<<endl;
}
return 0;
}
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
struct Tnode
{
char d;
Tnode *l,*r;
};
char st[60];
int i;
Tnode *CreatTree()
{
Tnode *p;
if(st[i++]==',')
p= NULL;
else
{
p=new Tnode;
p->d=st[i-1];
p->l=CreatTree();
p->r=CreatTree();
}
return p;
}
void level_order(Tnode *p) //层次遍历
{
queue<Tnode *>q;
if(p!=NULL)
q.push(p);
while(!q.empty())
{
p=q.front();
if(!p->l&&!p->r)
cout<<p->d;
q.pop();
if(p->l)
q.push(p->l);
if(p->r)
q.push(p->r);
}
}
int main()
{
while(cin>>st)
{
i=0;
Tnode *Tree=CreatTree();
level_order(Tree);
cout<<endl;
}
return 0;
}