Seeding

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=1100

ZOJ2100

It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares.

Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?


Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. 'S' is a square with stones, and '.' is a square without stones.

Input is terminated with two 0's. This case is not to be processed.


Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.


Sample Input

4 4
.S..
.S..
....
....
4 4
....
...S
....
...S
0 0


Sample Output

YES
NO


解题思路:用DFS搜索,如果搜索到这样一种情况:(搜索步数)step=(总数)total-石头数目(stone),就是‘YES’,否则就是‘NO’;题目比较水,但是有个问题值得注意一下,我一开始是用的string定义的字符串,结果一直“Segmentation Fault”,改成char定义的就AC了,汗,简直无语。


#include <iostream>
#include <string>
#include <cstring>
using namespace std;

char map[10][10];
bool flag;
int total, step, n, m;

void Solve(int x, int y)
{
	if(x < 0 || y < 0 || x >= n || y >= m || 'S' == map[x][y]) return ;

	map[x][y] = 'S';	
	step++;
	if(total == step)
	{
		flag = true;
		return ;
	}
	Solve(x, y+1);
	Solve(x, y-1);
	Solve(x+1, y);
	Solve(x-1, y);
	step--;
	map[x][y] = '.';
}

int main()
{
	std::ios::sync_with_stdio(false);
	int i, j;

	cin >> n >> m;
	while(n || m)
	{
		memset(map, 0, sizeof(map));
		total = n * m;
		flag = false;
		step = 0;
		for(i = 0; i < n; i++)
		{
			cin >> map[i];
			for(j = 0; j < m; j++)
			{
				if('S' == map[i][j])
					total--;
			}
		}

		Solve(0, 0);

		if(flag) cout << "YES" << endl;
		else cout << "NO" << endl;
		cin >> n >> m;
	}

	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值