hdu 1159 LCS 最长公共子序列

Common Subsequence
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 66199    Accepted Submission(s): 30781

 
Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
 
 
Sample Input
abcfbc abfcab programming contest abcd mnp
 
 
Sample Output
4 2 0

思路:

X的前i个元素组成的序列,Y的前j个元素组成的序列。

1.当xi = yi时,Xi-1和Yi-1的最长公共子序列 + 1.

2.当不等时,为Xi-1和Yj的最长公共子序列 与Xi 和Yj-1的最长公共子序列。

#include<iostream>
#include<cstdio>
using namespace std;
const int N = 1010;
int f[N][N];
char a[N], b[N];
int n, m;
int main() {
	while (cin >> a + 1 >> b + 1) {
		n = strlen(a + 1);
		m = strlen(b + 1);
		memset(f, 0, sizeof(f));
		for (int i = 1; i <= n; i++) {
			for (int j = 1; j <= m; j++) {
				if (a[i] == b[j]) {
					f[i][j] = max(f[i][j], f[i - 1][j - 1] + 1);
				}
				else {
					f[i][j] = max(f[i - 1][j], f[i][j - 1]);
				}
			}
		}
		cout << f[n][m] << endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值