A - Expanding Rods POJ - 1905(二分)

A - Expanding Rods POJ - 1905(二分)

题目

Problem Description

When a thin rod of length L is heated n degrees, it expands to a new length L’=(1+n*C)*L, where C is the coefficient of heat expansion.
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced.

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.
Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.
Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1
Sample Output

61.329
225.020
0.000

题解

数学公式推导后,对高度二分,上下限为 0 ~ 0.5杆长

二分精度控制

while(r-l > 1eN)
#include<bits/stdc++.h>
using namespace std;
double len2, len, c, n, legal, R;

int main(){
	freopen("test.in", "r", stdin);
	double ans, l, r, mid;
	while(scanf("%lf%lf%lf", &len, &n, &c) && len >= 0 && c >= 0 && n >= 0) {
		l = 0;
		r = 0.5*len;
		len2 = (1+n*c)*len;
		while(r-l > 1e-4) {
		//控制精度  r-l > 1eN 
			mid = (l + r) / 2;
			R = (len*len/4 + mid*mid) / 2 / mid;
			legal = asin(len / 2 / R);
			ans = 2 * R * legal;
			if(ans < len2) l = mid;
			else r = mid;
		}
		printf("%.3f\n", l);
	}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值