H - Fibonacci POJ - 3070 (矩阵快速幂)

H - Fibonacci POJ - 3070 (矩阵快速幂)

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1
Sample Output

0
34
626
6875
Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

利用矩阵快速幂求 fibonacci 数列第n项

题解

通过设未知数计算求解常数矩阵
利用矩阵快速幂简化计算

复杂度

O(logn) == 30

数据范围

n = 1e9
每次%10000,数据不大

算法

矩阵快速幂(二分)

代码

#include<bits\stdc++.h>
using namespace std;
#define mod 10000

typedef struct node {
	int e[3][3];
}Matrix;

Matrix mp, temp, ans;
int n;

void Mut(Matrix &a, Matrix &b, Matrix &c) { // 传递指针 
	memset(temp.e, 0, sizeof(temp.e));
	for(int i = 0; i <= 1; i++) {
		for(int j = 0; j <= 1; j++) {
			for(int k = 0; k <= 1; k++) {
				temp.e[i][j] += a.e[i][k] * b.e[k][j];
				temp.e[i][j] %= mod;
			}
		}
	}
	for(int i = 0; i <= 1; i++) {
		for(int j = 0; j <= 1; j++) {
			c.e[i][j] = temp.e[i][j];
		}
	}
}

void quick_mod(int power) {
	while(power) {
		if(power&1) {
			Mut(ans, mp, ans); // 将ans*mp存到ans里 
		}
		power >>= 1;
		Mut(mp, mp, mp); // a=mp b=mp c=a*b 
	}
}

int main() {
	freopen("test.in", "r", stdin);
	while(cin >> n && n != -1) {
		if(n == 0) {
			printf("0\n");
			continue;
		}
		mp.e[0][0] = 0;
		mp.e[0][1] = mp.e[1][0] = mp.e[1][1] = 1;
		ans.e[0][0] = ans.e[0][1] = 1;
		quick_mod(n-1); // 求第n项,即求 (1,1)*A^(n-1) 
		printf("%d\n", ans.e[0][0]);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值