Fibonacci POJ - 3070 矩阵快速幂

In the Fibonacci integer sequence, F0 = 0,F1 = 1, and Fn =Fn − 1 +Fn − 2 forn ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits ofFn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., printFn mod 10000).

Sample Input
0
9
999999999
1000000000
-1
Sample Output
0
34
626
6875
Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.


做这个题真的是开眼了,以前不知道有矩阵快速幂QAQ,看来矩阵快速幂是可以优化递推关系的

操作过程如同对数的快速幂,我自己推了一遍矩阵表达式,推出来的不是给出的那个,而是如下这个

(图是抄的)

这样的话就要>=1,当n是0的时候直接输出0就可以了。还有,用结构体里存放矩阵的话非常清晰方便,比不用来的要清晰简单得多。

#include<stdio.h>
#include<string.h>
using namespace std;
struct aa
{
    int m[3][3];
};
aa mx(aa a,aa b)
{
    aa res;
    memset(res.m,0,sizeof(res.m));
    for(int i=1; i<=2; i++)
        for(int j=1; j<=2; j++)
            for(int k=1; k<=2; k++)
            {
                res.m[i][j]+=(a.m[i][k]*b.m[k][j]);
                res.ma[i][j]%=10000;
            }
    return res;
}
int fast_mod(aa x,long long y)
{
    aa ans;
    ans.m[1][1]=ans.m[2][2]=1;
    ans.m[1][2]=ans.m[2][1]=0;
    while(y)
    {
        if(y&1)
        {
            ans=mx(ans,x);

        }
        y=y>>1;
        x=mx(x,x);
    }
    return ans.m[1][1];

}
int main()
{
    long long n;
    while(scanf("%lld",&n)!=EOF)
    {
        if(n<0)
            break;
        aa x;
        x.m[1][1]=x.m[1][2]=x.m[2][1]=1;
        x.m[2][2]=0;
        if(n==0)
            printf("0\n");
        else
        printf("%d\n",fast_mod(x,n-1));

    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值