Piggy-Bank(完全背包)

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.
Output Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".
Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4
Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.
题目大意是给你一个存钱罐的容量,再给你几种硬币的价值和重量,让你求出存钱罐中所能存放的最小金额。

因为每种硬币可以取无数次,所以这是个完全背包(dp)问题。

在写动态规划时要注意其3个特性:最优化原理,无后效性,重叠性具体参考  完全背包详解

在本题中的状态转移方程:dp[j] = min(dp[j-a[i].w]+a[i].p,dp[j]);//  j代表重量,dp[j]代表当前重量的金额。

我的理解是:对于每一个重量都有相对应的最有优解,一直叠加优化到背包的最大容量就可以得到最大容量时的最优解。


上代码:

#include <iostream>
#include <string>
#include <sstream>
#include <stdio.h>
#include <stdlib.h>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <ctime>
#include <vector>
#include <set>
#include <sstream>
#include <map>
#include <cctype>

using namespace std;
#define Start clock_t start = clock();
#define End clock_t end = clock();
#define Print cout<<(double)(end-start)/CLOCKS_PER_SEC*1000<<"ºÁÃë"<<endl;
#define INF 0x7fffffff
const int maxn = 10000 + 5;
int t,e,f,n;
struct Bank{
    int p,w;
}a[maxn];
int dp[maxn];

int main()
{
    cin>>t;
    while(t--){
        cin>>e>>f;
        int z = f - e; //计算差额重量,也就是钱币的重量  
        cin>>n;
        for(int i = 1;i <= n;i++){
           cin>>a[i].p>>a[i].w;
        }
        for(int i = 0;i <= z;i++)
            dp[i] = INF;//因为要求刚好装满,所以其他的取不到都赋值为无穷  
        int ans = 0;
        dp[0] = 0;
        for(int i = 1;i <= n;i++){//完全背包。顺序遍历所以可能转移的状态 
            for(int j = a[i].w;j <= z;j++){
             if(dp[j-a[i].w] != INF)//若不为负无穷,就是说这个可以取到 
             dp[j] = min(dp[j-a[i].w]+a[i].p,dp[j]);//取最小
            }
        }
        if(dp[z] != INF)//存在就输出  
            printf("The minimum amount of money in the piggy-bank is %d.\n",dp[z]);
        else
            printf("This is impossible.\n");
    }
    return 0;
}
请点赞!
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值