HDU1074 Doing Homework 状态压缩dp



Doing Homework

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9867    Accepted Submission(s): 4718


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework). 

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
 

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
 

Sample Input
      
      
2 3 Computer 3 3 English 20 1 Math 3 2 3 Computer 3 3 English 6 3 Math 6 3
 

Sample Output
      
      
2 Computer Math English 3 Computer English Math
Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.
 

Author
Ignatius.L

题意:有n个作业,每个作业都有一个截止时间和花费时间,如果某个作业超过截止时间一天,那么要减一分。问怎样安排作业顺序,使减少的分数最少。

解析:使用状态压缩dp。因为一共有15个作业,所以第i个作业可以用(1<<i)来表示,但所有作业都完成后的状态是1<<(n-1),所以另i从0开始,枚举0~1<<(n-1)这些状态。i可以由这样的数字past转移而来:past和i的二进制只有一位不同,且past那一位是0,i的那一位是1。具体见代码:

#include <stdio.h>
#include <string.h>
#define N (1<<15)+5
#define INF 0xfffffff
struct node{
	char name[101];
	int cost, deadline;
};
int dp[N], T[N], pre[N];
node hw[16];
void print(int x){
	if(!x)return;
	print(x - (1<<pre[x]));
	printf("%s\n", hw[pre[x]].name);
}
int main(){
	int t, n;
	scanf("%d", &t);
	while(t--){
		scanf("%d", &n);
		for(int i = 0; i < n; i++)
			scanf("%s%d%d", hw[i].name, &hw[i].deadline, &hw[i].cost);
		int end = 1 << n;
		T[0] = 0;
		for(int i = 1; i < end; i++){
			dp[i] = INF;
			for(int j = n-1; j >= 0; j--){
				int p = 1<<j;
				if(i & p){
					int past = i - p;
					int ti = T[past] + hw[j].cost - hw[j].deadline;
					if(ti < 0) ti = 0;
					if(dp[i] > dp[past] + ti){
						dp[i] = dp[past] + ti;
						T[i] = T[past] + hw[j].cost;
						pre[i] = j;
					}
				}
			}
		}
		printf("%d\n", dp[end-1]);
		print(end-1);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值