UESTC Training for Data Structures——J

Problem  J

Problem Description

An array of size n ≤ 10^6 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position  Minimum value  Maximum value
[1  3  -1] -3  5  3  6  7   -1  3
1 [3  -1  -3] 5  3  6  7   -3  3
1  3 [-1  -3  5] 3  6  7   -3  5
1  3  -1 [-3  5  3] 6  7   -3  5
1  3  -1  -3 [5  3  6] 7   3  6
1  3  -1  -3  5 [3  6  7]  3  7
Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

There are several cases in the input file, each case consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.

Output

There are two lines in the output for each input. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7
/*维护一个不降的双向队列求最大值
  维护一个不增的双向队列求最小值*/

#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
#define N 1000005
using namespace std;
int a[N],zhan[N];
int n,k;
void find_min()  //求最大值
{
    int head=0,tail=1;
    zhan[1]=1;
    for(int i=2;i<=k-1;i++)
    {
        if(a[i]<=a[zhan[head+1]]) { head=tail; zhan[++tail]=i; }
        else
        {
            while(tail!=head && a[zhan[tail]]>=a[i]) tail--;
            zhan[++tail]=i;
        }
    }
    for(int i=k;i<=n;i++)
    {
        if(tail-head==k) head++;
        if(a[i]<=a[zhan[head+1]]) { head=tail; zhan[++tail]=i; }
        else
        {
            while(tail!=head && a[zhan[tail]]>=a[i]) tail--;
            zhan[++tail]=i;
        }
        while(zhan[head+1]<=i-k) head++;
        printf("%d",a[zhan[head+1]]);
        if(i!=n) printf(" ");
    }
    printf("\n");
}
void find_max()  //求最小值
{
    int head=0,tail=1;
    zhan[1]=1;
    for(int i=2;i<=k-1;i++)
    {
        if(a[i]>=a[zhan[head+1]]) { head=tail; zhan[++tail]=i; }
        else
        {
            while(tail!=head && a[zhan[tail]]<=a[i]) tail--;
            zhan[++tail]=i;
        }
    }
    for(int i=k;i<=n;i++)
    {
        if(tail-head==k) head++;
        if(a[i]>=a[zhan[head+1]]) { head=tail; zhan[++tail]=i; }
        else
        {
            while(tail!=head && a[zhan[tail]]<=a[i]) tail--;
            zhan[++tail]=i;
        }
        while(zhan[head+1]<=i-k) head++;
        printf("%d",a[zhan[head+1]]);
        if(i!=n) printf(" ");
    }
    printf("\n");
}
int main()
{
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        if(k>n) k=n;
        memset(a,0,sizeof(a));
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        find_min();
        find_max();
    }
    return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
互联网络程序设计是指在互联网上进行程序开发和设计的过程。UESTC则是我国的一所著名高校——电子科技大学。 互联网络程序设计 uestc包含了两个主要的方面:互联网络和程序设计。互联网络是指将多个计算机网络通过通信链路互相连接起来,实现信息共享和资源共享的网络系统。程序设计是指根据需求和目标,通过编写代码和设计算法,实现计算机程序的过程。 互联网络程序设计 uestc的学习内容主要包括以下几个方面: 1. 网络知识:学习互联网络的基本概念、原理和协议,如TCP/IP协议、HTTP协议等。掌握网络编程的基本技术,能够编写网络应用程序。 2. 数据通信:学习数据通信的基本原理和技术,包括数据传输的方式、数据压缩和加密等。了解网络安全和数据保护的基本知识。 3. 程序设计:学习编程语言和开发工具,如Java、C++和Python等。掌握常用的编程技巧和方法,能够设计和实现复杂的网络应用程序。 4. Web开发:学习Web开发的基本知识和技术,包括HTML、CSS、JavaScript等。能够设计和实现交互式的Web应用程序。 5. 数据库技术:学习数据库的基本原理和技术,如SQL语言和数据库管理系统。能够设计和管理数据库,实现数据的存储和检索。 通过学习互联网络程序设计 uestc,可以掌握互联网应用开发的基本技能,具备设计和实现网络应用程序的能力。这对于目前互联网行业的人才需求来说是非常重要的,也为学生提供了广阔的就业和创业机会。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值