Prime Ring Problem
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 50957 Accepted Submission(s): 22556
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6 8
Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
题目大意:
给你一个整数N,在由这N个数构成的环中相邻两个数的和为素数,第一个数为1,求按照字典序大小输出的所有环
这道题我是用深度搜索求解的,从1开始递归,找一个数就标记一下,找到满足题意的就输出,返回后再取消标记,别忘了输出格式即可。
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int used[25],a[25],a1[25];
int n,ans;
int is_prime(int x)
{
if(x == 1)return 0;
for(int i = 2; i <= sqrt(x); i++)
{
if(x % i == 0)return 0;
else continue;
}
return 1;
}
void dfs(int x)
{
ans++;
a1[ans] = a[x];
if(ans == n)
{
if((is_prime(a1[1] + a1[n])))
{
for(int i = 1; i < n; i++)
printf("%d ",a1[i]);
printf("%d\n",a1[n]);
}
return;
}
for(int i = 1; i <= n; i++)
{
if(is_prime(a[i] + a[x]) && (!used[i]))
{
used[i] = 1;
dfs(i);
ans--;
used[i] = 0;
}
}
return;
}
int main()
{
int kase = 0;
while(scanf("%d",&n)==1)
{
for(int i = 1; i <= n; i++)
a[i] = i;
memset(used,0,sizeof(used));
printf("Case %d:\n",++kase);
ans = 0;
used[1] = 1;
dfs(1);
printf("\n");
}
return 0;
}