1129 Recommendation System (25分)

1129 Recommendation System (25分)

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user’s preference by the number of times that an item has been accessed by this user.

Input Specification:
Each input file contains one test case. For each test case, the first line contains two positive integers: N (≤ 50,000), the total number of queries, and K (≤ 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing – for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:
For each case, process the queries one by one. Output the recommendations for each query in a line in the format:
query: rec[1] rec[2] … rec[K]

where query is the item that the user is accessing, and rec[i] (i=1, … K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:

12 3
3 5 7 5 5 3 2 1 8 3 8 12

Sample Output:

5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

本题思路:先设置结构体node,并重载小于号,然后用set< node >来存储结果,同时因为重置了运算符所以会自动排序。每一次都输出set中的最前面的部分(数量小于k时全部输出,大于等于k时只输出k个),每一轮都会读入一个数,寻找在set中是否已存在,如果存在则需要删除那个数据,然后重新加入修改后的数据(set中的元素的值不能直接修改!!!),如果不存在,直接插入cnt=1的node即可,进入下一轮。

AC代码:

#include<iostream>
#include<set>
#include<algorithm>
using namespace std;

struct node{
    int number;
    int cnt;
    node(int a,int b)   {number=a,cnt=b;}
    bool operator < (const node &a) const{
        return cnt!=a.cnt ? cnt>a.cnt : number<a.number;
    };
};

int n;
int k;
set<node> ans;
int list[50010];


int main()
{
    cin >> n >>k;
    int t;
    cin >> t;
    ans.insert({t,1});
    list[t]++;
    for(int i=1;i<n;i++)
    {
        cin >> t;
        printf("%d:",t);
        int l=ans.size();
        if(l<=k)
        {
            for(auto it=ans.begin();it!=ans.end();it++)
                printf(" %d",(*it).number);
        }
        else
        {
            int p=0;
            for(auto it=ans.begin();p<k&&it!=ans.end();p++,it++)
                printf(" %d",(*it).number);
        }
        if(ans.find(node(t,list[t]))!=ans.end())
        {
            auto it=ans.find(node(t,list[t]));
            ans.erase(it);
            list[t]++;
            ans.insert({t,list[t]});
        }
        else
        {
            ans.insert({t,1});
            list[t]++;
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值