Arbitrage
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 24559 | Accepted: 10397 |
Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.
Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
Input
The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
Sample Input
3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0
Sample Output
Case 1: Yes Case 2: No
Source
题意:给你几种货币的利率,问你里面可不可以套汇
题解:和
poj1860 Currency Exchange 差不多,
spfa求“正环”。不过没告诉起点,所以每个点都要试下,如果一个点可以套汇,就直接YES,如果所有源点都试过了都不行,就输出NO。
代码如下:
#include<iostream>
#include<vector>
#include<queue>
#include<map>
#include<string>
#include<cstring>
using namespace std;
int n;
const int MAX = 35;
const int INF = 0x3f3f3f3f;
struct Edge{
int k;
double r;
Edge(int kk,double rr)
:k(kk), r(rr){
}
Edge();
};
vector < Edge > G[MAX];
double dist[MAX];
int vis[MAX];
int cnt[MAX];
int spfa(int start)
{
queue <int> que;
dist[start] = 1;
vis[start] = 1;
que.push(start);
while(!que.empty()){
int s = que.front();
que.pop();
vis[s] = 0;
for(int i = 0, j = G[s].size();i < j; ++i){
int d = G[s][i].k;
double tmp = dist[s] *G[s][i].r;
// cout << dist[d] << " " << tmp << "\n";
if(dist[d] < tmp){
dist[d] = tmp;
if(!vis[d]){
vis[d] = 1;
// cout << "d:" << d << "\n";
que.push(d);
}
}
}
//cout << dist[start] << "\n";
//cout << "dist[" << start <<"]:" << dist[start] << "\n";
if(dist[start] > 1) return 1;
}
return 0;
}
int main()
{
map<string,int> id;
string name;
int times = 0;
while(cin >> n && n){
for(int j = 0;j < MAX; ++j)
G[j].clear();
++times;
for(int j = 1;j <= n; ++j){
cin >> name;
id[name] = j;
}
int m;
cin >> m;
string ci,cj;
int a,b;
double rij;
while(m--){
cin >> ci >> rij >> cj;
a = id[ci]; b = id[cj];
G[a].push_back(Edge(b,rij));
}
int ok = 0;
for(int i = 1;i <= n; ++i){
memset(vis,0,sizeof(vis));
memset(dist,0,sizeof(dist));
memset(cnt,0,sizeof(cnt));
if(spfa(i)){
cout << "Case " << times <<": Yes\n";
ok = 1;
break;
}
}
if(ok)
continue;
else
cout << "Case " << times <<": No\n";
}
}