hdu3127WHUgirls【二维完全背包】

 

Problem Description
There are many pretty girls in Wuhan University, and as we know, every girl loves pretty clothes, so do they. One day some of them got a huge rectangular cloth and they want to cut it into small rectangular pieces to make scarves. But different girls like different style, and they voted each style a price wrote down on a list. They have a machine which can cut one cloth into exactly two smaller rectangular pieces horizontally or vertically, and ask you to use this machine to cut the original huge cloth into pieces appeared in the list. Girls wish to get the highest profit from the small pieces after cutting, so you need to find out a best cutting strategy. You are free to make as many scarves of a given style as you wish, or none if desired. Of course, the girls do not require you to use all the cloth.
 

 

Input

 

The first line of input consists of an integer T, indicating the number of test cases.
The first line of each case consists of three integers N, X, Y, N indicating there are N kinds of rectangular that you can cut in and made to scarves; X, Y indicating the dimension of the original cloth. The next N lines, each line consists of two integers, xi, yi, ci, indicating the dimension and the price of the ith rectangular piece cloth you can cut in.
 

 

Output

 

Output the maximum sum of prices that you can get on a single line for each case.

Constrains
0 < T <= 20
0 <= N <= 10; 0 < X, Y <= 1000
0 < xi <= X; 0 < yi <= Y; 0 <= ci <= 1000
 

 

Sample Input

 

 
1 2 4 4 2 2 2 3 3 9
 

 

Sample Output

 

 
9

 

 

 

就这么一个小破题 写了三天→_→

之前还想简单了(说白了就是写题没走脑子)

这个就是DP思路~~分块了而已 自己改了一遍也没对 WA的代码:

 

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,X,Y,t;
int dp[1005][1005],x[12],y[12],c[12];
int max(int a,int b,int c)
{
    if(a>b)
    {
        if(c>a) return c;
        return a;
    }
    if(c>b) return c;
    return b;
}
int main()
{
    //freopen("cin.txt","r",stdin);
    cin>>t;
    while(t--)
    {
        cin>>n>>X>>Y;
        for(int i=1;i<=n;i++) cin>>x[i]>>y[i]>>c[i];
        memset(dp,0,sizeof(dp));
        for(int k=1;k<=n;k++)
        {
        for(int i=0;i<=X;i++)
        {
            for(int j=0;j<=Y;j++)
            {

                    if(i>=x[k]&&j>=y[k])
                    dp[i][j]=max(dp[i][j],dp[i-x[k]][j]+dp[x[k]][j-y[k]]+c[k],dp[i][j-y[k]]+dp[i-x[k]][y[k]]+c[k]);
                    if(i>=y[k]&&j>=x[k])
                    dp[i][j]=max(dp[i][j],dp[i-y[k]][j]+dp[y[k]][j-x[k]]+c[k],dp[i][j-x[k]]+dp[i-y[k]][x[k]]+c[k]);
                }
            }
        }
        cout<<dp[X][Y]<<endl;
    }
    return 0;
}


为啥错呢?想了一下 dp的前后关系不是由方框的序号来的,只是由x,y的坐标值推导出来的~~所以大循环是坐标!

 

AC代码:

 

/*************
hdu3127
2015.10.27-2015.10.29
************/
#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,X,Y,t;
int dp[1005][1005],x[12],y[12],c[12];
int max(int a,int b,int c)
{
    if(a>b)
    {
        if(c>a) return c;
        return a;
    }
    if(c>b) return c;
    return b;
}
int main()
{
    //freopen("cin.txt","r",stdin);
    cin>>t;
    while(t--)
    {
        cin>>n>>X>>Y;
        for(int i=1;i<=n;i++) cin>>x[i]>>y[i]>>c[i];
        memset(dp,0,sizeof(dp));
        for(int i=0;i<=X;i++)
        {
            for(int j=0;j<=Y;j++)
            {
                for(int k=1;k<=n;k++)
                {
                    if(i>=x[k]&&j>=y[k])
                    dp[i][j]=max(dp[i][j],dp[i-x[k]][j]+dp[x[k]][j-y[k]]+c[k],dp[i][j-y[k]]+dp[i-x[k]][y[k]]+c[k]);
                    if(i>=y[k]&&j>=x[k])
                    dp[i][j]=max(dp[i][j],dp[i-y[k]][j]+dp[y[k]][j-x[k]]+c[k],dp[i][j-x[k]]+dp[i-y[k]][x[k]]+c[k]);
                }
            }
        }
        cout<<dp[X][Y]<<endl;
    }
    return 0;
}

 

 

 

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值