[POJ]1458-Common Subsequence

题目要求:

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
 

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
 

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
 

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

 

Sample Output

4
2
0

 

这道题是最纯的求最长公共子序列的题,用动态规划法求解即可。具体解法分析,请转至本博客的文章《动态规划求解最长公共子序列(LCS)》

以下是我的代码,欢迎各位大牛指导交流~

AC, 352K, 16MS

//POJ_1458
//written by zhou
//2013.11.15
#include <iostream>
#include <string>
using namespace std;

int main()
{
	
	string sx,sy;
	while (cin >> sx >> sy)
	{
		int sizex = sx.length();
		int sizey = sy.length();

		//创建动态二维数组
		int **lcs = new int*[sizex];
		for (int i = 0; i < sizex; ++i)
		{	
			lcs[i] = new int[sizey];
		}

		//求解LCS
		int max = 0;
		for (int i = 0; i < sizex; ++i)
		{
			for (int j = 0; j < sizey; ++j)
			{
				//计算初始值:lcs[0][x]和lcs[x][0]的值
				if (i == 0 || j == 0)
				{
					if (sx[i] == sy[j])
					{
						lcs[i][j] = 1;
					}
					else
					{
						if (i == 0 && j == 0)
							lcs[i][j] = 0;

						else if (i == 0 && j != 0)
							lcs[i][j] = lcs[i][j-1];

						else
                            lcs[i][j] = lcs[i-1][j];
					}

				}
				else  //其他lcs[i][j]的值
				{
					if (sx[i] == sy[j])
						lcs[i][j] = lcs[i-1][j-1] + 1;
					else 
						lcs[i][j] = lcs[i-1][j] > lcs[i][j-1] ? lcs[i-1][j] : lcs[i][j-1];
				}

				if (lcs[i][j] > max) 
					max = lcs[i][j];
			}
		}

		//释放动态二维数组
		for (int i = 0; i < sizex; ++i)
		{
			delete[] lcs[i];
		}
		delete[] lcs;

		cout << max << endl;
	}
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值