A - Bi-shoe and Phi-shoe LightOJ - 1370

3 篇文章 0 订阅
1 篇文章 0 订阅

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo’s length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.
Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].
Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.
Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

题意:Φ (n)表示长度为小于数字n的和n互质的数的个数,也就是欧拉函数。现在给出n个幸运数字,对于每一个幸运数字,要求的x,使Φ (x)的值大于等于这个幸运数字,求这些x和的最小值
that means 给出的每个数x,要求出一个值,它的的欧拉函数值要超过这个x,并且所有数的总和要最小
思路:想要求所有数的幸运值总和最小,那就让每个值都最小(贪心),怎么样才能最小呢?根据欧拉函数的性质,素数的欧拉函数值总是比较大,所以跟非素数比起来,它能实现尽可能欧拉函数值超过x,又能使本身值最小,
而且欧拉函数对于素数还有一个定理:对于素数的欧拉函数值Φ (p)=p-1.
所以,我们可以对每个给出的x,从x+1开始找素数,第一个找到的素数就是我们要找的最小值
知识点:素数打表(埃氏筛法),欧拉函数的性质

#include<iostream>
#define maxn 1000010
using namespace std;
int T;
int n,num;
int p[maxn]={0};
void find_prime(){
    for(int i=2;i<maxn;i++){
        if(p[i]==false){
            for(int j=i+i;j<maxn;j=j+i){
                p[j]=true;
            }
        }
    }
}
int main(){
    cin>>T;
    find_prime();
    for(int i=1;i<=T;i++){
        cin>>n;
        long long int ans=0;
        for(int j=0;j<n;j++){
            cin>>num;
            for(int k=num+1;k<maxn;k++){
                if(p[k]==false){
                    ans+=k;
                    break;
                }
            }
        }
        cout<<"Case "<<i<<": "<<ans<<" Xukha"<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值