Bi-shoe and Phi-shoe LightOJ - 1370题解 (贪心的思想,欧拉函数,素数打表)

题面:
    Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,
    Score of a bamboo = Φ (bamboo's length)
    (Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.
    The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.
Input
    Input starts with an integer T (≤ 100), denoting the number of test cases.
    Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].
Output
    For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.
Sample Input

    3

    5

    1 2 3 4 5

    6

    10 11 12 13 14 15

    2

    1 1
Sample Output

    Case 1: 22 Xukha

    Case 2: 88 Xukha

    Case 3: 4 Xukha
思路:
      Xukha首先可以想到素数的性价比是最高的。因为素数与比他小的每一个正整数都互质。 所以我们全部使用素数长度的竹子,所以对于每一个同学的幸运数,我只需要找到一个大于他的最小的素数就可以了。
代码:

#include<bits/stdc++.h>
using namespace std;
const int MAXN=2000000+10;
bool isprime[MAXN];//isprime[]表示i是不是质数
int prime[MAXN], tot;//prime[]用来存质数
void init(int N)
{
    memset(isprime,true,sizeof(isprime));  //初始化所有的数为质数
    for(int i=2;i<=N;i++)
    {
        if(isprime[i])
          prime[tot ++] = i;//把质数存起来
        for(int j=0;j<tot&&i*prime[j]<=N;j++)
        {
            isprime[i*prime[j]]=false;
            if(i%prime[j]==0)  break;//保证每个合数被它最小的质因数筛去
        }
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    init(MAXN-5);
    int t;
    scanf("%d",&t);
    int cas=1;
    while(t--)
    {
        long long ans=0;
        int n;
        scanf("%d",&n);
        while(n--)
        {
            int x;
            scanf("%d",&x);
            x++;
            if(isprime[x])
            {
                ans+=x;
                //cout<<n<<"  "<<x<<"\n";
                continue;
            }
            for(int i=x;;i++)
            {
                if(isprime[i])
                {
                    ans+=i;
                    //cout<<n<<" * "<<i<<"\n";
                    break;
                }
            }
        }
        printf("Case %d: %lld Xukha\n",cas++,ans);
    }
}



 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 4
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值