数论——exgcd:S - C Looooops POJ - 2115

A Compiler Mystery: We are given a C-language style for loop of type

for (variable = A; variable != B; variable += C)

  statement;


I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k.

Input
The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop.

The input is finished by a line containing four zeros.

Output
The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.
Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

题意:一个C语言的for循环,初始值是a,当等于b时跳出,步长为c,值只能在0~2^k里
问会循环多少次,如果永远跳不出循环,则输出forever
思路:就是问a+cxX=b能不能在0~2^k范围内得出X值
–>得出二元方程(a+cxX)%2^k=b
根据拓展欧几里得及同余推论得:(a+cxX)=b+(2^k)xY
化简得到:cX+2^k Y=b-a
化成我看着舒服的AX+BY=C
后面就都简单了
到得到最终的X值的步骤:
因为开始我们是用AX+BY=gcd(A,B)来算的
根据gcd(m,n) = gcd(n,m modn)
所以x要乘回来:X=XxC/gcd(A,B)
又因为X要在0~b/gcd(A,B)-1里面所以要对X取模:X=(X%b/gcd(A,B)+b/gcd(A,B))%b/gcd(A,B)

#include<iostream>
using namespace std;
typedef long long ll;
ll a,b,c,k,X,Y;
ll exgcd(ll A,ll B,ll& X,ll& Y){
    if(B==0){
        X=1;
        Y=0;
        return A;
    }else{
        ll g=exgcd(B,A%B,X,Y);
        ll tmp=X;
        X=Y;
        Y=tmp-A/B*Y;
        return g;
    }
}
int main(){
    while(cin>>a>>b>>c>>k){
        if(a==0&&b==0&&c==0&&k==0)break;//注意
        ll A=c;
        ll B=(1ll<<k);//二进制表示
        ll C=b-a;
        ll e=exgcd(A,B,X,Y);
        if(C%e!=0){
          cout<<"FOREVER"<<endl;
        }else{
            ll te=C/e;
            X*=te;
            X=(X%(B/e)+(B/e))%(B/e);
            cout<<X<<endl;
        }

    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值