1051: 魔咒词典

1051: 魔咒词典

时间限制: 1 Sec   内存限制: 128 MB
提交: 138   解决: 74
[ 提交][ 状态][ 讨论版]

题目描述

       哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

      给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”

输入

首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

    [魔咒] 对应功能

    其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
    词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

输出

 每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”

样例输入

[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky

样例输出

light the wand
accio
what?

what?

#include<iostream>
using namespace std;
int main()
{
	string a[10000];
	string b[10000];
	int k=0;
	char x,y;
	while(cin>>a[k]&&a[k]!="@END@")
	{
		cin.get();
		getline(cin,b[k]);
		k++;
	}
	int n;
	cin>>n;
	cin.get();     //cin和getline混用时需要加cin.get()吞掉末尾的换行符
	string c[10];
	for(int i=0;i<n;i++)
		getline(cin,c[i]);
	for(int i=0;i<n;i++)
	{
		if(c[i][0]=='[')
		{
			int count(0);
			for(int j=0;j<k;j++)
			{
				if(a[j]==c[i])
				{
					cout<<b[j]<<endl;
					count=1;
				}
			}
			if(count==0)
				cout<<"what?"<<endl;
		}
		else
		{
			int count(0);
			for(int j=0;j<k;j++)
				if(b[j]==c[i])
				{
					for(int m=1;a[j][m]!=']';m++)
						cout<<a[j][m];
					cout<<endl;
					count=1;
				}
			if(count==0)
				cout<<"what?"<<endl;
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

mypollyanna

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值