Find the result of the following code:
long long pairsFormLCM( int n ) {
long long res = 0;
for( int i = 1; i <= n; i++ )
for( int j = i; j <= n; j++ )
if( lcm(i, j) == n ) res++; // lcm means least common multiple
return res;
}
A straight forward implementation of the code may time out. If you analyze the code, you will find that the code actually counts the number of pairs (i, j) for which lcm(i, j) = n and (i ≤ j).
Input
Input starts with an integer T (≤ 200), denoting the number of test cases.
Each case starts with a line containing an integer n (1 ≤ n ≤ 1014).
Output
For each case, print the case number and the value returned by the function ‘pairsFormLCM(n)’.
Sample Input
15
2
3
4
6
8
10
12
15
18
20
21
24
25
27
29
Sample Output
Case 1: 2
Case 2: 2
Case 3: 3
Case 4: 5
Case 5: 4
Case 6: 5
Case 7: 8
Case 8: 5
Case 9: 8
Case 10: 8
Case 11: 5
Case 12: 11
Case 13: 3
Case 14: 4
Case 15: 2
给出一个数,求有多少对(a,b)(a<=b) 使得lcm(a,b) = n;
由算术基本定理可知 n = p1^e1 * p2 ^e2 ….pn^en;
那么a = p1^a1 * p2 ^ a2 …… pn^an;
b = p1^b1 * p2 ^ b2 …… pn^bn;
要使得lcm(a,b) 为 n ,那么对于每一个 pi ,都有max(ai,bi) = ei;
所以当a1 = e1 时,b1 可以取 0 到 e1 ,共 e1 + 1 种取法,
当a1 != e1 时,b1 只能取 e1, 共有 e1 种取法
所以对于每个p ,都有 2 * e1 + 1种取法,故总取法为所有相乘,又有a <=b,
故最后结果 除以 2 ;
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<queue>
#include<algorithm>
#define ll long long
#define inf 0x3f3f3f3f
#define maxn 10000007
using namespace std;
int prime[1000100];
bool vis[maxn];
int cnt = 0;
void find_prime()
{
vis[0] = 1;
vis[1] = 1;
for(int i = 2; i < maxn; i ++)
{
if(vis[i] == 0)
{
prime[cnt++] = i;
for(int j = i+i; j < maxn; j += i)
{
vis[j] = 1;
}
}
}
}
int main()
{
int t;
ll n;
find_prime();
scanf("%d",&t);
for(int k = 1; k <= t; k ++)
{
scanf("%lld",&n);
int i = 0;
ll ans = 1;
while( i < cnt && prime[i] <= n)
{
if( n % prime[i] == 0)
{
int count = 0;
while( n % prime[i] == 0)
{
count ++;
n /= prime[i];
}
ans *= 2*count + 1;
}
i ++;
}
if( n > 1) // 防止n中有的素因子大于打表求出的
ans *= 2 * 1 + 1;
printf("Case %d: %lld\n",k,(ans+1) / 2) ;
}
return 0;
}