picture

Give you the width and height of the rectangle,darw it.

Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.
Sample Input
3 2
Sample Output
+---+
|   |
|   |
+---+

这个题的意思是每组数据的第一个是m个-,第二个是n个|,这样一来就很好理解了。我最先想到的就是利用for循环,以+号开头,把后面的依次多用几个for循环就可以解出来,代码如下:

#include <stdio.h>
#include <stdlib.h>
#include<string.h>
int main()
{
    int i,j,n,m;
    char s[1000][1000];
    while(~scanf("%d%d",&m,&n))
    {s[0][0]='+';s[0][m+1]='+';
    s[n+1][0]='+';s[n+1][m+1]='+';
    for(i=1;i<=m;i++)
    {
        s[0][i]='-';
        s[n+1][i]='-';
    }
    for(i=1;i<=n;i++)
    {
        s[i][0]='|';
        s[i][m+1]='|';
    }
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=m;j++)
        {
            s[i][j]=' ';
        }
    }
    for(i=0;i<=n+1;i++)
    {
        for(j=0;j<=m+1;j++)
        {
            printf("%c",s[i][j]);
        }
        printf("\n");
    }
    printf("\n");}
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值