max num

There are some students in a class, Can you help teacher find the highest student .

Input
There are some cases. The first line contains an integer t, indicate the cases; Each case have an integer n ( 1 ≤ n ≤ 100 ) , followed n students’ height.
Output
For each case output the highest height, the height to two decimal plases;
Sample Input
2
3 170.00 165.00 180.00
4 165.00 182.00 172.00 160.00
Sample Output
180.00
182.00

这个题是一道很简单的题,但我中间却走了一点弯路。我刚开始的时候我把数组里面的元素用排序的方法找出最大的然后输出,结果超时了,,,然后我才想到对于这个问题而言直接比较出最大值输出就行,就写出了下面的代码:

#include <stdio.h>
#include <stdlib.h>
int main()
{
    int n,cnt,i,j;
    double a[100],max;
    while(~scanf("%d",&cnt))
    {
        for(j=0;j<cnt;j++)
        {
        max=0;
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%lf",&a[i]);
        }
        for(i=0;i<n;i++)
        {
            if(a[i]>max)
                max=a[i];
        }
        printf("%.2lf\n",max);
    }}
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值