九度oj-素数环

题目:

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1

输入:

n (1 < n < 17).

输出:

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.

样例输入:

6
8

样例输出:

 

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

解题思路:

dfs和回溯的又一好例子,注意return的用法。

# include<stdio.h>
# define N 17
int prime[]={2,3,5,7,11,13,17,19,23,29,31,37};//这题重点并不在于求解素数本身

int n;
bool hash[N];
int ans[N];

bool check(int x)
{
	for(int i=0;i<12;i++)
	{
		if(x==prime[i])
			return true;
	}
	return false;
}

void final_put()
{
	if(check(ans[n]+ans[1])==false)//不往下执行了
		return;

	else
	{
		for(int i=1;i<=n;i++)
		{
			if(i==1)
				printf("%d",ans[i]);
			else
				printf(" %d",ans[i]);
		}
		printf("\n");
	}
}

void dfs(int num)
{
    if(num>=2)
	{
        if(check(ans[num]+ans[num-1])==false)//回退上一级
			return;
	}
	
	if(num==n)//设成全局变量
	{
		final_put();
		return;//回退上一级
	}
    
	for(int i=2;i<=n;i++)//遍历
	{
		if(hash[i]==false)
		{
			hash[i]=true;
			ans[num+1]=i;
			dfs(num+1);//调用

			hash[i]=false;//全部调用完成后,返回时赋值。
		}
	}
}

int main()
{
	int i;
	int mycase=0;
	while(scanf("%d",&n)!=EOF)
	{
        mycase++;
		printf("Case %d:\n",mycase);
        //初始化
		for(i=1;i<N;i++)
		{
			hash[i]=false;
			ans[i]=-1;
		}

		hash[1]=true;
		ans[1]=1;

		dfs(1);
		printf("\n");
	}
	return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值