PAT 1110 Complete Binary Tree

题目链接:

1110 Complete Binary Tree
Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:
For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

思路:
判断一个二叉树是不是完整二叉树,从根节点开始,依次放入队列,如果左子树或者右子树为空,则记为-1,同时加入队列。通过层次遍历,到第一次出队时为-1时结束,统计这时候已经便利了的节点数,如果等于总的节点数+1(因为包含了刚出队为-1的节点),那么则为完整二叉树。否则不是完整二叉树。

#include <iostream>
#include<cstdio>
#include<queue>
using namespace std;
struct node{
	int left,right;
}tree[25];
queue<int> Q; 
int in[25];
int root=0,last=-1,num=0;
void bfs(){
	Q.push(root);
	while(!Q.empty()){
		num++;
		int front=Q.front();
		Q.pop();
		if(front!=-1) last=front;
		else break;
		Q.push(tree[front].left);
		Q.push(tree[front].right);
	}
}
int main(int argc, char** argv) {
	int n;
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		string l,r;
		cin>>l>>r;
		if(l[0]=='-') tree[i].left=-1;
		else{
			in[stoi(l)]++;
			tree[i].left=stoi(l);
		} 
		if(r[0]=='-') tree[i].right=-1;
		else{
			in[stoi(r)]++;
			tree[i].right=stoi(r);
		} 
	}
	while(in[root]) root++;
	bfs();
	if(num-1!=n){
		printf("NO %d\n",root);
	}else{
		printf("YES %d\n",last);
	}
	return 0;
}

参考思路:
http://www.cnblogs.com/BlueBlueSea/p/9939813.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值