pat 1110. Complete Binary Tree (25)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line "YES" and the index of the last node if the tree is a complete binary tree, or "NO" and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:
9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -
Sample Output 1:
YES 8
Sample Input 2:
8
- -
4 5
0 6
- -
2 3
- 7
- -
- -
Sample Output 2:
NO 1

判断二叉树是否为完全二叉树:

层序遍历时,记录访问过的结点数目,当该结点没有孩子结点时,结束遍历,若访问过的节点数目不为n时,则不为完全二叉树。

注意:n<20,不是小于10,要把字符转化成数字。

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
#include<vector>
#include<algorithm>
#include<queue>
#define MS(a,b) memset(a,b,sizeof(a))
int last,n,cnt;
vector<int>v;
struct node
{
    int left,right,fa;
}tree[200];
void bfs(int root)
{
    int rt;
    queue<int>q;
    q.push(root);
    while(!q.empty())
    {
      rt=q.front();
      q.pop();
     if(rt!=-1)
     {
        last=rt;//最后一个结点。
        cnt++;//访问过结点的数目。
     }
       if(rt==-1)break;
        q.push(tree[rt].left);
        q.push(tree[rt].right);
    }
}
int main()
{
    /*#ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
    freopen("out.txt","w",stdout);
    #endif*/
    int i;
    char s1[5],s2[5];
    scanf("%d",&n);
    for(i=0;i<n;i++)
        tree[i].left=tree[i].right=tree[i].fa=-1;
   for(i=0;i<n;i++)
   {
       cin>>s1>>s2;
       if(s1[0]!='-')
         {  sscanf(s1,"%d",&tree[i].left);//将字符转化为数字。
            tree[tree[i].left].fa=i;
         }
       else tree[i].left=-1;
       if(s2[0]!='-')
         {  sscanf(s2,"%d",&tree[i].right);
            tree[tree[i].right].fa=i;
         }
       else tree[i].right=-1;
   }
   int root=-1;
   for(i=0;i<n;i++)
    if(tree[i].fa==-1)
       {root=i;break;}
       cnt=0;
        bfs(root);
     if(cnt==n)
      printf("YES %d\n",last);
     else  printf("NO %d\n",root);
    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
To convert the given array to a complete BST, we need to perform the following steps: 1. Sort the array in ascending order 2. Construct a complete binary tree using the sorted array 3. Perform inorder traversal of the binary tree and store the elements in the original array in the same order as the traversal Here's the implementation of the to_bst(lst) function in Python: ```python def to_bst(lst): # Sort the input list lst.sort() # Construct a complete binary tree using the sorted list n = len(lst) if n == 0: return lst root = lst[n // 2] left_subtree = to_bst(lst[:n // 2]) right_subtree = to_bst(lst[n // 2 + 1:]) binary_tree = [root] + left_subtree + right_subtree # Perform inorder traversal of the binary tree and store the elements in the original array inorder_traversal(binary_tree, lst, 0) return lst def inorder_traversal(binary_tree, lst, i): # Perform inorder traversal of the binary tree and store the elements in the original array n = len(binary_tree) if i >= n: return inorder_traversal(binary_tree, lst, 2 * i + 1) lst[i] = binary_tree[i] inorder_traversal(binary_tree, lst, 2 * i + 2) ``` The to_bst(lst) function takes in the input list and returns the same list after converting it to a complete BST. The function first sorts the input list in ascending order. It then constructs a complete binary tree using the sorted list by recursively dividing the list into two halves and setting the middle element as the root of the binary tree. Finally, the function performs an inorder traversal of the binary tree and stores the elements in the original list in the same order as the traversal.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值