Kindergarten Counting Game
Kindergarten Counting Game |
Everybody sit down in a circle. Ok. Listen to me carefully.
``Woooooo, you scwewy wabbit!''
Now, could someone tell me how many words I just said?
Input and Output
Input to your program will consist of a series of lines, each line containing multiple words (at least one).A ``word'' is defined as a consecutive sequence of letters (upper and/or lower case).
Your program should output a word count for each line of input. Each word count should be printed ona separate line.
Sample Input
Meep Meep! I tot I taw a putty tat. I did! I did! I did taw a putty tat. Shsssssssssh ... I am hunting wabbits. Heh Heh Heh Heh ...
Sample Output
2 7 10 9
AC 代码如下
#include <stdio.h>
#include <string.h>
#include <ctype.h>
#define MAXN 100+10
char str[MAXN];
int main(void)
{
int i, n, word;
char oldch;
while (fgets(str, MAXN, stdin) != NULL) {
n = strlen(str);
word = 0;
oldch = str[0];
for (i=1; i<n; ++i) {
if (isalpha(oldch) && !isalpha(str[i]))
++word;
oldch = str[i];
}
printf("%d\n", word);
}
return 0;
}