Counting Game

There are n people standing in a line, playing a famous game called counting". When the game begins, the leftmost person says1" loudly, then the second person (people are numbered 1 to n from left to right) says 2" loudly. This is followed by the 3rd person saying3" and the 4th person say 4", and so on. When the n-th person (i.e. the rightmost person) saidn" loudly, the next turn goes to his immediate left person (i.e. the (n - 1)-th person), who should say n + 1" loudly, then the (n - 2)-th person should sayn + 2" loudly. After the leftmost person spoke again, the counting goes right again.

There is a catch, though (otherwise, the game would be very boring!): if a person should say a number who is a multiple of 7, or its decimal representation contains the digit 7, he should clap instead! The following tables shows us the counting process for n = 4(`X’ represents a clap). When the 3rd person claps for the 4th time, he’s actually counting 35.

在这里插入图片描述

Given n, m and k, your task is to find out, when the m-th person claps for the k-th time, what is the actual number being counted.

Input
There will be at most 10 test cases in the input. Each test case contains three integers n, m and k
(2 ≤ n ≤ 100, 1 ≤ m ≤ n, 1 ≤ k ≤ 100) in a single line. The last test case is followed by a line with
n = m = k = 0, which should not be processed.
Output
For each line, print the actual number being counted, when the m-th person claps for the k-th time. If
this can never happen, print ‘-1’.

Sample Input
4 3 1
4 3 2
4 3 3
4 3 4
0 0 0
Sample Output
17
21
27
35
题意:第一个人喊1,第二个人喊2,第三个人喊3,按顺序接着喊,直到n个人喊完之后,倒数第二个人接着往上喊,倒数第三个接着喊,喊到第一个人之后,第二个人接着喊,也就是说在第一个和最后一个不重复,。若是某个人喊到7或者含有7的不喊或者鼓掌,问你第m个人鼓掌k次之后总数喊到多少了。
思路:2*n-2一个循环,然后进行判断即可。

#include"cstdio"
#include"iostream"
#include"cstring"
#include"algorithm"
using namespace std;
#define manx 1000005 
int zml(int x)
{
	if(x%7==0)
	{
		return 1;
	}
	while(x)
	{
		if(x%10==7)
		{
			return 1;
		}
		x/=10;
	}
	return 0;
}
int main()
{
	int n,m,k,a[1005];
	while(~scanf("%d %d %d",&n,&m,&k))
	{
		if(n==0&&m==0&&k==0)
		{
			break;
		}
		else
		{
			for(int i=1;i<=n;i++)
			{
				a[i]=i;
			}
			int t=n-1;
			for(int i=n+1;i<=2*n-2;i++)
			{
				a[i]=t;
				t--;
			}
			int sum=0,i;
			for(i=1;i<manx;i++)
			{
				if(zml(i)==1)
				{
					if(i%(2*n-2)==0)
					{
						if(a[2*n-2]==m)
						{
							sum++;
						}
					}
					else
					{
						if(a[i%(2*n-2)]==m)
						{
							sum++;
						}
					}
				}
				if(sum==k)
				{
					printf("%d\n",i);
					break;
				}
			}
			if(i==manx)
			{
				printf("-1\n");
			}
		}
		
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
完整版:https://download.csdn.net/download/qq_27595745/89522468 【课程大纲】 1-1 什么是java 1-2 认识java语言 1-3 java平台的体系结构 1-4 java SE环境安装和配置 2-1 java程序简介 2-2 计算机中的程序 2-3 java程序 2-4 java类库组织结构和文档 2-5 java虚拟机简介 2-6 java的垃圾回收器 2-7 java上机练习 3-1 java语言基础入门 3-2 数据的分类 3-3 标识符、关键字和常量 3-4 运算符 3-5 表达式 3-6 顺序结构和选择结构 3-7 循环语句 3-8 跳转语句 3-9 MyEclipse工具介绍 3-10 java基础知识章节练习 4-1 一维数组 4-2 数组应用 4-3 多维数组 4-4 排序算法 4-5 增强for循环 4-6 数组和排序算法章节练习 5-0 抽象和封装 5-1 面向过程的设计思想 5-2 面向对象的设计思想 5-3 抽象 5-4 封装 5-5 属性 5-6 方法的定义 5-7 this关键字 5-8 javaBean 5-9 包 package 5-10 抽象和封装章节练习 6-0 继承和多态 6-1 继承 6-2 object类 6-3 多态 6-4 访问修饰符 6-5 static修饰符 6-6 final修饰符 6-7 abstract修饰符 6-8 接口 6-9 继承和多态 章节练习 7-1 面向对象的分析与设计简介 7-2 对象模型建立 7-3 类之间的关系 7-4 软件的可维护与复用设计原则 7-5 面向对象的设计与分析 章节练习 8-1 内部类与包装器 8-2 对象包装器 8-3 装箱和拆箱 8-4 练习题 9-1 常用类介绍 9-2 StringBuffer和String Builder类 9-3 Rintime类的使用 9-4 日期类简介 9-5 java程序国际化的实现 9-6 Random类和Math类 9-7 枚举 9-8 练习题 10-1 java异常处理 10-2 认识异常 10-3 使用try和catch捕获异常 10-4 使用throw和throws引发异常 10-5 finally关键字 10-6 getMessage和printStackTrace方法 10-7 异常分类 10-8 自定义异常类 10-9 练习题 11-1 Java集合框架和泛型机制 11-2 Collection接口 11-3 Set接口实现类 11-4 List接口实现类 11-5 Map接口 11-6 Collections类 11-7 泛型概述 11-8 练习题 12-1 多线程 12-2 线程的生命周期 12-3 线程的调度和优先级 12-4 线程的同步 12-5 集合类的同步问题 12-6 用Timer类调度任务 12-7 练习题 13-1 Java IO 13-2 Java IO原理 13-3 流类的结构 13-4 文件流 13-5 缓冲流 13-6 转换流 13-7 数据流 13-8 打印流 13-9 对象流 13-10 随机存取文件流 13-11 zip文件流 13-12 练习题 14-1 图形用户界面设计 14-2 事件处理机制 14-3 AWT常用组件 14-4 swing简介 14-5 可视化开发swing组件 14-6 声音的播放和处理 14-7 2D图形的绘制 14-8 练习题 15-1 反射 15-2 使用Java反射机制 15-3 反射与动态代理 15-4 练习题 16-1 Java标注 16-2 JDK内置的基本标注类型 16-3 自定义标注类型 16-4 对标注进行标注 16-5 利用反射获取标注信息 16-6 练习题 17-1 顶目实战1-单机版五子棋游戏 17-2 总体设计 17-3 代码实现 17-4 程序的运行与发布 17-5 手动生成可执行JAR文件 17-6 练习题 18-1 Java数据库编程 18-2 JDBC类和接口 18-3 JDBC操作SQL 18-4 JDBC基本示例 18-5 JDBC应用示例 18-6 练习题 19-1 。。。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值