UVa - 494 - Kindergarten Counting Game 题解

Everybody sit down in a circle. Ok. Listen to me carefully.

``Woooooo, you scwewy wabbit!''

Now, could someone tell me how many words I just said?

Input and Output

Input to your program will consist of a series of lines, each line containing multiple words (at least one). A ``word'' is defined as a consecutive sequence of letters (upper and/or lower case).

Your program should output a word count for each line of input. Each word count should be printed on a separate line.

Sample Input

Meep Meep!
I tot I taw a putty tat.
I did! I did! I did taw a putty tat.
Shsssssssssh ... I am hunting wabbits. Heh Heh Heh Heh ...

Sample Output

2
7
10
9

这里的题目有点不太清楚,因为有一种情况我开始也忽视了:

jfle..............ioo89839jji

这里其实是算3个单词,算成一个单词就错了。

还有就是注意处理行间信息

#include <string>
#include <iostream>
using namespace std;

bool mIsAlpha(char a)
{
	return 'a' <= a && a <= 'z' || 'A' <= a && a <= 'Z';
}

void KindergartenCountingGame()
{
	string s;
	while (getline(cin, s))
	{
		int c = 0;
		bool sp = true;
		for (int i = 0, j = 0; i < s.size(); i++)
		{
			if (!mIsAlpha(s[i])) sp = true;
			else if (sp && mIsAlpha(s[i]))
			{
				c++;
				sp = false;
			}
		}
		cout<<c<<endl;
	}
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值