poj1724:ROADS

Description

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins).
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash.

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way.
The second line contains the integer N, 2 <= N <= 100, the total number of cities.

The third line contains the integer R, 1 <= R <= 10000, the total number of roads.

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters :

  • S is the source city, 1 <= S <= N
  • D is the destination city, 1 <= D <= N
  • L is the road length, 1 <= L <= 100
  • T is the toll (expressed in the number of coins), 0 <= T <=100


Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins.
If such path does not exist, only number-1 should be written to the output.

Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

Sample Output

11

题目大意

给定n个城市以及m条道路,道路描述如下:s,d,l,t分别表示起点,终点,长度,花费,为有向道路,现在某人有k钱币,问从1能否到达n,若能则输出在满足花费不超过k的情况下的最短路径长度,不能则输出-1。

思路

这道题主要思路就是模拟链表+简单的dfs,时间挺短的,代码也很好理解。

当然如果你是dalao,也可以用邻接表。

还有其实三维数组+dfs也能做……

不会模拟链表的——>https://blog.csdn.net/zhuyifan_jizhi/article/details/81221813嘿嘿嘿

代码

#include<iostream>
#include<cstring>
using namespace std;
int minn=0x7ffffff;//minn开到最大 
int k,n,r,first[100001],visit[100001];// first控制模拟链表的下标,visit避免dfs重复 
struct node {
    int s,d,l,t,next;
} road[100001];
void dfs(int begin,int money,int len) {//分别为出发城市,剩余钱数,长度 
    if(len>minn) return;//剪枝 
    if(len<minn&&begin==n) {//满足条件 
        minn=len;//更新最小值 
        return;
    }
    for(int i=first[begin]; i!=-1; i=road[i].next) {
        if(visit[road[i].d]&&road[i].t<=money) {
            visit[road[i].d]=0;
            dfs(road[i].d,money-road[i].t,len+road[i].l);
            visit[road[i].d]=1;//回溯 
        }
    }

}
int main() {
    int nnn;
    cin>>nnn;
    while(cin>>k) {
        minn=0x7ffffff;
        cin>>n>>r;
        int a,b,c,d;
        memset(first,-1,sizeof(first));
        memset(visit,1,sizeof(visit));
        for(int i=0; i<r; i++) {
            cin>>a>>b>>c>>d;
            road[i].s=a;
            road[i].d=b;
            road[i].l=c;
            road[i].t=d;
			//模拟链表初始化 
            road[i].next=first[road[i].s];
            first[road[i].s]=i;
        }
        dfs(1,k,0);
        if(minn<0x7ffffff) cout<<minn<<endl; 
        else cout<<-1<<endl;
    }
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值