1724:ROADS

1724:ROADS
查看提交统计提示提问
总时间限制: 1000ms 内存限制: 65536kB
描述
N cities named with numbers 1 … N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins).
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash.

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.
输入
The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way.
The second line contains the integer N, 2 <= N <= 100, the total number of cities.

The third line contains the integer R, 1 <= R <= 10000, the total number of roads.

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters :
S is the source city, 1 <= S <= N
D is the destination city, 1 <= D <= N
L is the road length, 1 <= L <= 100
T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.
输出
The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins.
If such path does not exist, only number -1 should be written to the output.
样例输入
5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2
样例输出
11
来源
CEOI 1998

/*
ROADS
思路,深搜加剪枝,包括可行性剪枝,最优性剪枝 
*/

#include<iostream>
#include<cstring>
#include<vector>
using namespace std;

struct Road{
	int d,l,t;
};

vector<vector<Road> > cityMap(110);	//cityMap[i]表示从源点i有路连接到其他城市
int minLen = 1 << 30;
int totalCost;
int totalLen;
int visited[110];
int minL[110][10010];		//minL[K][M]表示走到k点,花费为M的最短路径长度 
int K,N,R;


void dfs(int s)
{
	if(s == N){
		minLen =  min(minLen,totalLen);
		return;
	}
	
	for(int i = 0;i < cityMap[s].size();++i){
		int d = cityMap[s][i].d;	//有路连接到d
		if(!visited[d]){
			int cost = totalCost + cityMap[s][i].t;
			if(cost > K)	//可行性剪枝,花费超过限定值则直接退出 
				continue;
			//最优性剪枝,如果当前路长度大于记录下的最短长度,则退出
			//如果在相同花费下,当前长度大于之前记录下的长度,退出 
			if(totalLen + cityMap[s][i].l >= minLen || 
			totalLen + cityMap[s][i].l >= minL[d][cost])
				continue;
			totalLen += cityMap[s][i].l;
			totalCost += cityMap[s][i].t;
			minL[d][cost] = totalLen;
			visited[d] = 1;
			dfs(d); 
			totalLen -= cityMap[s][i].l;
			totalCost -= cityMap[s][i].t;
			visited[d] = 0;
		} 
	}
}

int main()
{

	cin >> K >> N >> R;
	
	//初始化边
	for(int i = 0;i < R;++i){
		int s;
		Road r;
		cin >> s >> r.d >> r.l >> r.t;
		if(s != r.d)
			cityMap[s].push_back(r);
	}
	memset(minL,0x3f,sizeof(minL));		//初始化为无穷大 
 	memset(visited,0,sizeof(visited));
	 
	totalLen = 0;
	totalCost = 0;
	visited[1] = 1;
	minLen = 1 << 30;
	dfs(1);
	if(minLen < (1 << 30))
		cout << minLen << endl;
	else
		cout << -1 << endl; 
	return 0;
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值