A1033. To Fill or Not to Fill (25)

1033. To Fill or Not to Fill (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
ZHANG, Guochuan

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax(<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300
Sample Output 1:
749.17
Sample Input 2:
50 1300 12 2
7.10 0
7.00 600
Sample Output 2:
The maximum travel distance = 1200.00
 
 
此题典型的贪心算法,可用直接解法,也可用深度遍历。

#include<cstdio>
#include<algorithm>

using namespace std;

const double INF = 100000000;

struct Station{
	double gas_price;
	double dis;
}st[505];

bool cmp(Station a, Station b)
{
	return a.dis < b.dis;
}

int main()
{
	double Cmax, Dis_total, Dis_Avg;
	int n;
	scanf("%lf %lf %lf %d", &Cmax, &Dis_total, &Dis_Avg, &n); 
	for(int i = 0; i < n; ++i)
	{
		scanf("%lf %lf", &st[i].gas_price, &st[i].dis);
	}
	st[n].gas_price = 0;
	st[n].dis = Dis_total;
	sort(st, st + n, cmp);
	if(st[0].dis != 0)
	{
		printf("The maximum travel distance = 0.00\n");
	}else{
		int now = 0;//当前加油站编号
		//总油钱, 装满油能跑最远距离 , 当前油量
		double ans = 0, MAX = Dis_Avg * Cmax, now_gas = 0;
		while(now < n)
		{
			int k = -1;
			double price_min = INF;
			for(int i = now + 1; i <= n && st[i].dis <= st[now].dis + MAX; ++i)//在加满油能到达的加油站内遍历,找油价尽量低的加油站
			{
				if(st[i].gas_price < price_min)
				{
					price_min = st[i].gas_price;
					k = i;
					if(price_min < st[now].gas_price) break;
				}
			} 
			if(k == -1) break;  //油满状态下到不了加油站,退出循环
			//当能到达下一加油站,计算转移费用
			double need = (st[k].dis - st[now].dis) / Dis_Avg;//从now站到k站需要的油
			if(price_min < st[now].gas_price)//如果要k站油价比now站低,加到刚好能到达k站的油
			{
				if(need > now_gas)//如果当前油不够去k站的
				{
					ans += (need - now_gas) * st[now].gas_price;//加满刚好到k站的油
					now_gas = 0;//到k站后油为0
				}else{  //油量够去k站,就直达k站
					now_gas -= need;
				}
			}else{  //如果k站油和now站油价相同或比now站高 加满油
				ans += (Cmax - now_gas) * st[now].gas_price;  //加满到k站油
				now_gas = Cmax - need; //剩下油为Cmax减去从now站到k站消耗的
			}
			now = k; //当请已到k站
		} 
		if(now == n)//可以到终点站
			printf("%.2f\n", ans);
		else 
			printf("The maximum travel distance = %.2f\n", st[now].dis + MAX);//从now站加满油也到不了下一站  输出最远到达的距离
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值