PAT Have Fun with Numbers

1 篇文章 0 订阅

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!
Now you are suppose to check if there are more numbers with this property. That is, double a given number with kk digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.
Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.
Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.
Sample Input:

1234567899
Sample Output:

Yes
2469135798

【题目大意】:有一类像123456789的数,将其乘2后的数位组成是一样的(246913578)。同样的数还有1234567899等等

我的代码:

#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
    int i, j=0, len, temp, pl,len1;
    int a = 0;
    char ch[100] = { 0 };
    char zh[100] = { 0 };
    gets(ch);
    len = strlen(ch);
    for (i = len - 1; i >= 0; i--)
    {
        temp = ch[i] - '0';
        pl = temp * 2;
        zh[j++] = pl-(pl+a)/10*10 + a + '0';

        if (pl >= 10)
            a = pl / 10;
        else
            a = 0;

    }
    if (a == 1)
    {
        zh[len] = 1 + '0';
        zh[len + 1] = '\0';
        printf("No\n");
        len1 = strlen(zh);
        for (j = len1 - 1; j >= 0; j--)
            printf("%c", zh[j]);
        return 0;
    }
    else
        zh[len] = '\0';

    len1 = strlen(zh);
    for (j = 0; j < len1; j++)
    {
        for (i = 0; i < len; i++)
        {
            if (zh[j] == ch[i])
                break;
        }
            if (i == len)
            printf("No\n");

    }
    if (j==len1)
        printf("Yes\n");
    for (j = len1 - 1; j >= 0; j--)
        printf("%c", zh[j]);
    return 0;
}

判定结果:
这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值