1001. A+B Format (20)

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991
/*本题理应可以按照字符串加法计算的方式来做,不过会比较烦,先用int计算出结果,再寻找逗号输出的位置会大大减少代码量*/
#include<stdio.h>
int main(){
	int a,b,sum;
	int i,j,flag=0;
	int digit=1;
	int partition[3];//将计算后的数分为3个部分,即每出现一个逗号算做一个部分结束,如000,024,568(数据最大为200,000,0)
	scanf("%d%d",&a,&b);
	sum = a+b;
	if(sum<0){
		printf("-");
		sum=-sum;
	}
	partition[0] = sum;
	for(j=1;j<=6;j++)
		partition[0]/=10;//计算第一部分,可能为0
	partition[1] = sum - partition[0]*1000000;
	for(j=1;j<=3;j++)
		partition[1]/=10;//计算第二部分,可能为0
	partition[2] = sum - partition[1]*1000 - partition[0]*1000000;//计算第三部分,同样可能为0
	i=0;
	while(!flag&&i<3){//flag==1代表发现了第一个不为0的部分并将其输出了,则此部分之后的数无论是否为0,都必须按3位输出,如partition【1】= 000
		if(partition[i]||i==2){
			printf("%d",partition[i]);
			if(i!=2)printf(",");//个位输出后不输出逗号
			flag = 1;
		}
		i++;
	}
	while(i<3){//输出剩下的部分,%03d,即全部按3位输出
		printf("%03d",partition[i]);
		if(i!=2)printf(",");//个位输出后不输出逗号
		i++;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值