1017. Queueing at Bank (25)

题目地址:https://www.patest.cn/contests/pat-a-practise/1017


1017. Queueing at Bank (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2
 
 



#include<iostream>
#include<algorithm>
#include<string.h>

using namespace std;

struct customer{
	int arrive_time, server_time, long_time, wait_time;//到达时间,开始服务的时间,时长,等待时间
	int server_window;//在哪个窗口进行服务
} cus [10000];

int server_time[100];//服务窗口可以开始进行下次服务的时间,用数字表示,0代表8:00:00,
//1代表8:00:01,一次类推


int time2num(int hour, int minute, int second){// 8:00:00 = 0, 8:00:01 = 1
	int base = 8 * 60 * 60;
	int time = hour * 3600 + minute * 60 + second;
	return time - base;
}

bool compare(customer a, customer b){
	return a.arrive_time < b.arrive_time;
}

/*找出最早可以提供服务的窗口*/
int find_server(int k){
	int num = -1, min = -1;
	for (int i = 0; i < k; i++){
		if (server_time[i] < min || min == -1){
			num = i;
			min = server_time[i];
		}
	}
	return num;
}


int main(){
	int n, k;
	cin >> n >> k;
	int count = 0;
	customer temp;
	int hour, minute, second, latest;
	latest = time2num(17, 0, 0);
	memset(server_time, 0, 100*sizeof(int));

	for (int i = 0; i < n; i++){
		cin >> hour;
		getchar();
		cin >> minute;
		getchar();
		cin >> second;
		getchar();
		temp.arrive_time = time2num(hour, minute, second);
		cin >> temp.long_time;
		temp.long_time *= 60;
		if (temp.arrive_time <= latest){//17:00以后来的不服务
			cus[count] = temp;
			if (cus[count].long_time > 3600)//每个人最多被服务1小时
				cus[count].long_time = 3600;
			count++;
		}
	}

	sort(cus, cus + count, compare);//最后能被服务的只有count个人

	for (int i = 0; i < count; i++){
		cus[i].server_window = find_server(k);
		cus[i].server_time = server_time[cus[i].server_window];
		if (cus[i].server_time < cus[i].arrive_time)//服务时间不可能早于到达时间
			cus[i].server_time = cus[i].arrive_time;
		cus[i].wait_time = cus[i].server_time - cus[i].arrive_time;
		server_time[cus[i].server_window] = cus[i].server_time + cus[i].long_time;
	}

	int total = 0;
	double average;
	for (int i = 0; i < count; i++){
		total += cus[i].wait_time;
	}
	average = total * 1.0 / 60 / count;
	printf("%.1f\n", average);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值